Support » Themes and Templates » Firefox cutting my content

  • Resolved fabian.schmid

    (@fabianschmid)


    Hi folks,

    I’ve been trying to fix this problem like a hundred times and every time I ended up giving up and taking care of some other bugs or new features etc. I wanna get rid of this now though.

    On fabians.ch/featuredlinks, Chrome and IE let you scroll down all the way till the link saying “Creative Mornings”. Firefox cuts the content after the link “European Design” (at least on my screen and settings).

    When I change the height of the class .sixcol (the two sidebars) to 5000px, the full content is being displayed, so it for some reason cuts the content right when the sidebars are finished. I tried to add height:auto to the .sixcol class, though it does not help. Also, adding overflow:auto to the .entry-container class did not change anything.

    Can someone help me? I would love you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey Fabian, have a look at the html of your section id=”content”. The div it wraps has an inline setting for height. In Chrome it appears as height:auto !important, in Firefox as height:0px! (would love to know why) See if you can remove that inline style, it doesn’t seem to be needed in Chrome anyway, and by removing it the problem disapears in Firefox.

    Regards,
    Zoran

    Hey zvitez, thanks for your reply! Unfortunately I have not seen it until just now. I somehow did not get email notifications.

    I have set the height:auto! myself because I-dunno-why… I think it was even related to this whole problem.

    Though I had it like this:

    #content . entries {
    	height:auto!important;
    }

    (see the space in front of entries?!)

    and now changed it to the following:

    #content .entries {
    	height:auto!important;
    }

    And it works like a charm!

    I cannot f*ing believe I did not see this and spent hours and hours on trying to fix this issue.

    Thanks again for leading me to having a look at this line again:)
    F

    Hey, it’s always the simplest things that cause the most frustration right? 🙂 Glad to have helped!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Firefox cutting my content’ is closed to new replies.