WordPress.org

Forums

[resolved] Firefox creates a BLACK screen half way through blog posts!?! (14 posts)

  1. SAphoto
    Member
    Posted 6 years ago #

    Please take a look at this post :
    http://saphoto.ca/blog/2008/10/04/hillary-amp-brians-wed-at-the-old-mill-in-ancaster/
    (and go make some coffee while a hundred and some pictures load…)

    If you are using IE or Chrome, everything will be fine. If you're using Firefox on a PC however, you will see a black screen appearing half way through the post as shown in this picture:
    http://i73.photobucket.com/albums/i215/saphoto4/BLOG/greenapple.jpg

    The theme I'm using is Green Apples (http://wordpress.org/extend/themes/green-apples), and even the guy that built it doesn't know what the problem is.

    I've posted this problem a lot of places and nobody can figure it out. While it may be a good idea to create posts with less pictures, this is NOT the solution I'm looking for. The particular problem does not happen with other themes.

    Note that the post in question was imported from wordpress.com (http://saphoto.wordpress.com) and that the pictures are hosted on photobucket.com.

    There are no plugins installed on the theme. I re-installed wordpress and the apple theme from scratch on a new website I got yesterday and the same thing happened.

    I'll be forever indebted to whoever can help me solve this!
    Sebastien

  2. RoseCitySister
    Member
    Posted 6 years ago #

    Hi - I'm the female-type "guy" who built it, but I do know that the problem is not with the theme. I really don't know why it's happening, because like I told you, there is no black in that theme - the only background color used anywhere in it is white.

    I double checked the theme and there is no fixed height set in the pages so that's not it either. I am stumped. I would like to see someone offer the answer though, just to satisfy my curiosity.

    I hate that you're having problems with Green Apples. I've never seen this before and have no idea of what's causing it. Sorry I can't be of more help.

    If it matters, when I view that page in Mac using Firefox it looks fine. Takes a very long time to load though. Maybe some computers just crap out from all the photos? Or maybe it's a problem with the photobucket feed? Please tell me why you need so many photos on one page? That's very user UNfriendly! Not trying to dis you hon, just offering good advice.

    Liane

  3. popper
    Member
    Posted 6 years ago #

    Hey SAphoto. I downloaded a copy of your page's HTML and while I didn't manage to make the black go completely away, I managed to make it go further down by removing junk bits of code like

    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    
    <code>
    </code>
    <code>
    </code>
    
    <code>
    </code>

    That's at the very top of your post. I'd suggest looking at the post in html view and search for things like that, see if it changes anything. At least we'll know in which direction to go.

    Also, the WC3 validator throws a gazillon errors due to using & as a character in the alt="" of the image. You could try changing that?

  4. SAphoto
    Member
    Posted 6 years ago #

    Oh Liane! I'm sorry I assumed you were a male! I guess I thought "Web" was a dude and that it was your name :). Thanks for all your help.

    And I don't mean to blame your theme.. I like it very much and that's why I'm posting everywhere so that it can be used without this problem of mine. I just posted this in the firefox support forum as well. Hopefully someone will resolve the mystery somewhere!

    Future posts are likely to include less pictures. When you go on the main blog: http://saphoto.ca/blog it's not nearly as crowded as there's only one picture preview of every entries. I use my blog as a summary of the wedding day (instead of a best-of). I can tell you that the brides like it very much. Theoretically someone who clicks on the blog entry is interested in reading more. But like I said I'm heading toward putting less (it's less work too). For now I'm just waiting for someone to fall from the sky with a magic fix... :)

  5. SAphoto
    Member
    Posted 6 years ago #

    Hi Julia,

    It should be noted that I'm an HTML and CSS idiot.. I do what I can with what I know :)

    On the main blog, I put a small picture (linked to the blog entry itself) with a text beside it.

    The junk code


    is the only way I found to make sure that the first picture is BELOW the small picture, and not beside it. If I don't do that it's all over the place, sometimes below the text on the right, but to the right of the picture.

    I'm of course opened to better solutions :)

  6. Saurus
    Member
    Posted 6 years ago #

    I had no problem loading the entire page quickly and completely. No "black" at all. Using FF2.

  7. SAphoto
    Member
    Posted 6 years ago #

    MAC or PC? It seems people with MAC don't have the problem...

  8. SAphoto
    Member
    Posted 6 years ago #

    Liane this is from from a guy (mmmmmm.. could be a girl! I have been wrong before hehe) on the firefox forum:

    "The blog post is too long. It's causing an integer overflow in the layout (known problem).

    If only the Green Apples theme causes it, then use a different theme or contact the author (knowing that the container of the post is too long will probably help fix it).

    An option would be to split it up in to multiple posts, or use smaller images (thumbnails), or put multiple images on the same line, or to use a proper gallery."

    The link to the "known problem" is this:
    https://bugzilla.mozilla.org/show_bug.cgi?id=215055

    As far as I'm concerned, it may as well be Chinese...

  9. SAphoto
    Member
    Posted 6 years ago #

    oh and here's the link to the firefox support forum post I made:
    http://forums.mozillazine.org/viewtopic.php?f=38&t=1192325

  10. SAphoto
    Member
    Posted 6 years ago #

    Ok I think I'm starting to understand Chinese... looks like we're going somewhere starting on comment 64 of the support forum:

    "-- Comment #64 From Deven Phillips 2008-05-21 13:20:42 PDT --
    I suppose that technically, I could go in and modify the CSS for XWiki (etc...)to not use "overflow: auto", but what about other users who are not as technically adept or do not have access to modify the sites that they are viewing?!?!"

    I don't know much but it sounds like changing the "overflow: auto" to "some code I don't know..." would easily fix the problem.

    Liane I hope this means something to you. And I'm wondering if you used the auto overflow in your zeeb theme because I didn't have this problem with it?

    thanks again...........

  11. RoseCitySister
    Member
    Posted 6 years ago #

    So it's a Firefox thing? Hmmm...

    The container of the post is as long as the post is - there's not a fixed height on anything except the header.

    I suggest that in future, if you want to put a lot of pics into one post, to use something like NextGen gallery slideshow - it's pretty nice and would be a nice way of displaying your talent. That first bride was radiant, you really brought captured her beauty in the photos.

  12. RoseCitySister
    Member
    Posted 6 years ago #

    Just reread your question. On lines 47 and 318 of style.css, on #page and #container, remove this code:

    overflow: auto;

    Then reload the page and see if that does it.

  13. SAphoto
    Member
    Posted 6 years ago #

    EUREKA!!! :))))))

    Liane, I went to your other theme zeeb and searched for "overflow", and there was no "auto" so I concluded this was indeed the problem (actually, firefox is the problem but...). Only "scroll" and "hidden" were showing.

    I tried to change both lines to "scroll" (remember that I have no idea what this means!) and that didn't do anything. But when I tried to change the "auto" to "hidden", BINGO! The black screen disappeared!

    The best thing is that I did this before you told me to check line 47 and 318. I'm proud of my accomplishment :))

    Definitely a firefox issue.

    BTW if "hidden" has other undesirable effects I should know about please let me know...

    Thanks again very much :)
    Sebastien

  14. RoseCitySister
    Member
    Posted 6 years ago #

    You can just take that whole line out. I used it because when I first built that theme, was having problems with the container div stretching and the solution was presented to me as an alternative to using a clearing div. I won't use it again, that's for sure.

    Sebastien, you're my hero of the day! This was driving me nuts. Talented and smart - your wife is a lucky woman! ;)

Topic Closed

This topic has been closed to new replies.

About this Topic