Support » Themes and Templates » firefox container problem

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    (@esmi)

    Forum Moderator

    You’ve got some validation errors that may be causing problems – especially the missing start and end tags. You could also do with changing <div id="topcont"> to <div class="topcont">. There should only ever be 1 named id in a page, so if you intend to use something more than once, assign it a class – not an id.

    In terms of the page background, I can’t see any difference between the display in FF3 and that in IE8.

    i see the errors but have no idea how to fix them. I’ve been trying to switch things around but all i seem to get is more errors.

    if your talking about the grid type background, you need to change the css for the body background image from no-repeat to repeat-y.

    no I’m talking about how the tan background only covers half of the page in firefox. esmi validation errors website probably found the problem but i don’t understand what it wants me to do

    esmi

    (@esmi)

    Forum Moderator

    viceng is right. You need to edit style.css (line 168)

    #mainpage {
    background-color:#FFFFCC;
    background-image:url(http://www.sketchygrid.com/images/bg_2.png);
    background-position:right top;
    background-repeat:repeat-y;
    border-right:1px solid #000000;
    min-height:1000px;
    padding:0 10px 10px;
    width:100%;
    }

    and change background-repeat:no-repeat; to background-repeat:repeat-y;

    I tried that originally and thought it wasn’t working. However, I’ve just pulled down a copy of the background image and I can see why. It’s an 800px high image – most of which is actually plain yellow. Not sure you’ll be happy with the result when you do get it tiling down the page.

    just changed it-and its still getting cut off. even with the repeat the background dies.

    Line 181, Column 22: document type does not allow element “div” here; assuming missing “li” start-tag
    <div class="topcont2"><h3>Meta</h3><ul>

    Line 195, Column 6: end tag for “li” omitted, but OMITTAG NO was specified
    </ul>

    not sure what these mean, to see where i got these from please look at esmi’s validation error link.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘firefox container problem’ is closed to new replies.