Support » Plugin: Cache Enabler - WordPress Cache » Firefox 666

  • It was indeed good news when Firefox added webp support in Firefox 65. And this works fine with Cache Enabler, as Firefox 65 adds “image/webp” to the Accept request header, both when making image requests, and for the document.

    However, Firefox 66.0 has changed the behavior. It still adds “image/webp” to image requests, but no longer adds it for documents. This means that Cache Enabler fails to serve webp files to Firefox 66.

    Do you have any idea on how to overcome this?

    I have thought about inspecting the User-Agent header, looking for Firefox/66 and above. However, it is possible for users to disable webp support in Firefox. That setting will probably only be used by very few people, but still.

    Perhaps you could let the user decide. That is, add an option if Cache Enabler should serve the webp version to Firefox 66 and above.

    PS: I created this topic on github as well: https://github.com/keycdn/cache-enabler/issues/52

Viewing 1 replies (of 1 total)
  • Plugin Author keycdn

    (@keycdn)

    Well, this is a bad change in FF 66. The missing image/webp in the Accept header is a problem. There doesn’t seem to be an easy fix. As you mentioned already, checking the User-Agent could be wrong if the user disables WebP.

    We’ve added this to our backlog to find a solution to identify if Firefox 66+ supports WebP.

Viewing 1 replies (of 1 total)
  • The topic ‘Firefox 666’ is closed to new replies.