Support » Plugin: WordPress HTTPS (SSL) » Filters going into endless loop

  • Resolved Jason Judge


    I set /my-account/ as a filter to force SSL on that URL and its sub-pages. That URL maps to a single page with a WooCommerce login form in it (using a smart tag).

    Now, when I go to that page, the browser going into a loop swicthing back and forth between SSL and non-SSL, until the browser gives up with a “error in redirection” message.

    Now, if I set the SSL flag of the my-account page to checked, then this loop does not happen. So somehow, not having the “Enable SSL” flag on the page set will force the SSL access to jump to non-SSL, even though the page is set in this plugin as SSL filtered page. Should the filter not override the setting on an individual page? Or could there be some other plugin or setting that is causing the “Enable SSL” flag on a page to take precedence over the filter settings for the same page?

    tl;di – the filter setting in this plugin for my-account causes my-account to jump to HTTPS. The unset “Enable SSL” flag on the my-account page causes it to jump back to HTTP. This goes on until the browser gives up. Why would they clash in this way? I don’t have to set the same thing in TWO places, do I?

Viewing 2 replies - 1 through 2 (of 2 total)
  • My workaround, for the moment, is to set the “Enable SSL” flags for pages that need to be forced into SSL, and NOT use this plugin at all. That is not ideal for the long term, as I have a lot of pages to update, and soon some routes will not be mapping onto WordPress pages, so there will not be a flag to set for these.

    I found the cause of this endless loop. As usual with WordPress, too many plugins try to do too much, and there is a lot of overlap ultimately causing conflicts.

    The “Better WP Security” plugin has an SSL section in its settings. Inside there, in the SSL tab, is a setting “Enforce Front end SSL”. I needed to switch that to “Off” for this plugin to work. I had no idea the “Enable SSL” checkbox in the posts and pages was actually generated by that plugin when “Enforce Front end SSL” is On.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Filters going into endless loop’ is closed to new replies.