Support » Plugin: Advanced AJAX Product Filters » Filter not working when change from one to another

  • webshuk

    (@webshuk)


    Hey,
    I am having some troubles with the plugin.
    When I first select an option on a filter it updates normally and every thing works fine.
    But when I change from option 1 to option 2 in the same filter, it doesn’t find any products. Also, when I change back from option 2 to option 1 it doesn’t show any of the products.
    After I reset the selection with the reset button or with unselect filter option and then I choose an option it shows the products of that option.

    It doesn’t show in the videos the dropdown for some reason..
    Hope you can help me with this issue.
    Thank you,
    Ofri

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RazyRx

    (@razyrx)

    Hello,

    You have two different filters for same attribute and it cause the issue.
    It seems one uses for mobile devices, when another for desktop, please setup it as two different group and set option Hide this group on to different values.

    Regards,
    Oleg

    Thread Starter webshuk

    (@webshuk)

    Hey,
    Thank you for your fast reply.
    I have set the filters according to your instruction.
    I have 2 groups with different filter for mobile and for desktop.
    I have set the option for each to show only on intended screen.
    yet, The problem still occurring, when I check which filters are active I see all of them are active regardless of how I set to hide them on mobile/desktop.
    It seems that “Hide this group on” doesn’t fix this issue
    Please advise.
    Thank you,
    Ofri

    Plugin Author RazyRx

    (@razyrx)

    Hello,

    Checked your site and both filters same as before displayed for both mobile and desktop https://imgur.com/a/cnYcDUh

    Do you use those groups to display filters?

    Regards,
    Oleg

    Thread Starter webshuk

    (@webshuk)

    Yes,
    I have 10 filters (5 for mobile and 5 for desktop)
    I have set 2 groups, 1 for desktop and 1 for mobile.
    I have set set the mobile group to hide on desktop and vice verse.
    It seem that the hide function doesn’t apply as I can see both filter groups in mobile and in desktop.

    Plugin Author RazyRx

    (@razyrx)

    Hello,

    What widget or shortcode do you use to display filters?
    Do you use widget/shortcode for each filter or you use widget/shortcode for group?

    To work correct 5 filters for mobile must be added to mobile group and 5 filters for desktop must be added to desktop group, then those groups must be displayed(not filters) with [br_filters_group] shortcode or AAPF Filters Group widget.

    Regards,
    Oleg

    Thread Starter webshuk

    (@webshuk)

    Hey,
    I have set the filters excacly as you described, but all of them are showing all the time.
    This Is the mobile group and how it is set.
    [URL=https://imageshack.com/i/pmpfx4URp][IMG]https://imagizer.imageshack.com/v2/xq90/922/pfx4UR.png[/IMG][/URL]
    This is example for how mobile filter is set.
    [URL=https://imageshack.com/i/ponbCQkpp][IMG]https://imagizer.imageshack.com/v2/xq90/924/nbCQkp.png[/IMG][/URL]

    Yet it still shows on desktop and vice versa.
    It seem that the hide function doesn’t work.
    Please Advise.
    Thank you,
    ofri

    Plugin Author RazyRx

    (@razyrx)

    Hello,

    You do not need to set “Hide this filter on” option if you used Groups.

    How did you displayed Groups on the page? Is it Two different sidebar or some page builder?

    Regards,
    Oleg

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Filter not working when change from one to another’ is closed to new replies.