Support » Plugin: YITH WooCommerce Ajax Product Filter » Filter not working in categories

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter danielaromeo

    (@danielaromeo)

    Hello,
    this is becoming urgent, could you please tell me how can I fix it?

    Thank you,
    Daniela

    Plugin Author YITHEMES

    (@yithemes)

    Hi @danielaromeo,

    for this you need to check your frontend configuration. For this you can read this post: Ajax Product filter frontend configuration

    After this make sure that your theme don’t change the standard WC_Query. you can solve this issue in this way:

    If Ajax Product Filter does not show filters or not show results for attributes / categories / tags if you’re using WooCommerce 2.6.x, please, follow these simple steps:

    1. Update the plugin to version 3.0.6 or higher

    If you have an active cache plugin, please, do also the following:

    2. Go to WooCommerce > System Status > Tools and click on recount terms

    3. Empty the cache (if any)

    If still the filters do not show up:

    4. copy and paste the following code into the functions.php file of your current theme:

    add_filter ('yith_wcan_use_wp_the_query_object', '__return_true');

    and go through steps 2 and 3 once again.

    Another reason that can cause this kind of problem is the register_sidebar of your theme. Many users complain that they do not see the filter or reset the widget list is not updated, the problem in most cases is this:

    The problem is in the before_widget arg in register sidebar settings. The correct way to register a sidebar is: ‘before_widget’ => ‘<li id = “% 1 $ s” class = “widget% 2 $ s”>’, with id and class params, like you read in the WordPress Codex . Your theme use only classes and not the id..
    Please, look here: https://codex.wordpress.org/Function_Reference/register_sidebar

    That amends must do the theme developer otherwise the first update will lose all changes.

    Let me know if you need more help or you can solve your issue.
    Have a nice day
    YITH

    Thread Starter danielaromeo

    (@danielaromeo)

    Hello YITH,
    thank you for the reply.
    I checked the CSS configuration and it’s fine, my theme does not change the main WC classes in the code.
    I also followed steps 2, 3 and 4 (and then 2 and 3 again).
    Regarding step 1, I have WC 2.6.11 and the most updated version is 2.6.14, so I don’t understand what is the 3.0.6 version you’re talking about. Regarding YITH plugin, I have version 3.1.0 and cannot update to the latest one, because there’s a bug in the hierarchical dropdown, items are listed alphabetically and the hierarchy is completely messed up.
    I checked sidebar registration in the theme and it’s correct. Anyway, I use this code to embed the filter in the page: <?php echo do_shortcode(‘[widgets_on_pages id=”filter”]’); ?> in archive-product.php template of the theme (child theme developed by me).
    Nothing worked, the filter is not working when inside a category.
    I hope the additional information I sent you could be useful to understand what I must fix in order to make it work.

    Thank you,
    Daniela

    Hello everybody
    I have this problem too and when I click on a category, All the categories products load. Every options and notes recommended by plugin author have been done (rally everything).
    I’ve worked so hard for 4 days and It’s a really unknown issue for me.
    I’ve checked everything and it doesn’t word.
    What can I do? please help me.
    By the way, I use WC 2.6.14 and Ajax Product Filter 3.1.3.
    Thank you in advance.

    Plugin Author YITHEMES

    (@yithemes)

    Hi @danielaromeo and @pssco

    I’m sorry for this. Probably we have a conflict with other products. Please, try to deactivate all plugins and see if the problem disappear. If so, try to activate them again one by one and see which one produces the issue.
    If the problem is not from a plugin, try to activate the default theme Twenty Sixteen or Twenty Seventeen and see if you have the same issue.

    Also, if you have customized files in your theme, please try with a fresh installation without customization.

    Remember that if you have a plugin for the cache, you need to delete the cache before to disable it.

    I’m waiting to hear you again.
    Have a nice day
    YITH

    Thread Starter danielaromeo

    (@danielaromeo)

    Hi YITH,
    I finally did all the tests you suggested and there seems to be a conflict with WPML plugins. If I disable all of them, the filter is working properly.
    Please let me know if there’s a way to solve this, I cannot turn off WPML on my website.

    Thank you,
    Daniela

    Plugin Author YITHEMES

    (@yithemes)

    Hi @danielaromeo,

    the plugin works fine with WPML, however I send your reporting to our developers to test it.

    Thanks for your reporting.

    Have a nice day
    YITH

    Thread Starter danielaromeo

    (@danielaromeo)

    Hi YITH,
    we’ve been able to solve the issue finally along with WPML support team.
    We had another plugin installed called “WooCommerce Products Filter”, that was causing the issue with WPML and your plugin. We removed it and everything worked well!

    Thank you for your support!

    Have a nice day,
    Daniela

    Plugin Author YITHEMES

    (@yithemes)

    Hi Daniela,

    thanks to you for this information.

    If you like our plugins and our support remember to give us a good review 🙂

    Have a nice day

    YITH

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Filter not working in categories’ is closed to new replies.