Support » Plugin: Pixel Caffeine » Filter by product stock

  • In the “Filter by product stock” option in the session
    “Product Filters” for the generation of the product catalog FEED I cannot insert any content.
    Clicking on the field starts a Searching that does not return any options.

    WordPress: Versione 5.6.2
    Pixel Caffeine: Versione 2.3.0
    Browser: all

Viewing 5 replies - 1 through 5 (of 5 total)
  • 3bson

    (@3bson)

    Same here – and it’s urgent because you better not to have problems at Facebook as they may put some penalty on your account.

    When you click on the field “Filter by product stock” while trying to edit product feed and type something down, the value of this input field got erased when clicking out.

    WordPress: 5.7
    Pixel: 2.3.3
    PS: I forced it to work, by putting “in stock’ value by javascript into fields. But nom I’m getting errors on page load, as I broke some of your code:D Here is the error, if that even helps:

    jquery.min.js?ver=3.5.1:2 Uncaught Error: Syntax error, unrecognized expression: [{"id":"in stock","text":"In Stock"},{"id":"out of stock","text":"Out of Stock"},{"id":"preorder","text":"Pre-Order"},{"id":"discontinued","text":"Discountinued"},{"id":"available for order","text":"Available for order"}]
        at Function.se.error (jquery.min.js?ver=3.5.1:2)
        at se.tokenize (jquery.min.js?ver=3.5.1:2)
        at se.select (jquery.min.js?ver=3.5.1:2)
        at Function.se (jquery.min.js?ver=3.5.1:2)
        at Function.s.find (jquery-migrate.min.js?ver=3.3.2:2)
        at S.fn.init.find (jquery.min.js?ver=3.5.1:2)
        at s.fn.init.S.fn.init (jquery.min.js?ver=3.5.1:2)
        at new s.fn.init (jquery-migrate.min.js?ver=3.3.2:2)
        at S (jquery.min.js?ver=3.5.1:2)
        at String.<anonymous> (admin.js?ver=2.3.3:1)
    FuzzGuard

    (@fuzzguard)

    We are having the same issue.

    We cannot enter in stock statuses to the field “Filter by product stock”. All we see is a spinning load icon and nothing happens in the background, ie. “Network” in developer tools. Also cannot see any javascript errors.

    Same problem here, tried multiple browsers just in case. I can confirm the workaround suggested above: inspecting the element and adding value=”in stock” to the corresponding input.

    I hope this gets fixed soon.

    Same issue here!!

    stormymondays

    (@stormymondays)

    Unfortunately this still hasn’t been solved. I hope there’s an update soon.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.