Support » Plugin: WooCommerce » Filter by attribute is no longer working

  • Resolved lilcreativedev

    (@lilcreativedev)


    Hi,

    The filter by attribute stopped working a couple of days ago. I have tried everything from deactivating all plugins, trying with Storefront, rolling back WordPress etc

    I have found one solution which is to roll back WC all the way to 5.5.4. Any newer versions and the Filter by Attributes stops working again.

    Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    I had a similar issue, even though I use a filter plugin and, at first, I thought this plugin was the cause of this problem. But as it strangely occured after upgrading Woocommerce to v6.3.1, I douted it.

    Here is what solved my problem:

    • In Woocommmerce > Settings > Products tab > Advanced, I enabled the use of the Woocommerce attribute lookup table (that I never enabled before!), and saved parameters
    • Then I regenerated the lookup table (just to be sure), via WooCommerce > Status > Tools
    • Back in Woocommmerce > Settings > Products tab > Advanced, I disabled the use of the Woocommerce attribute lookup table and saved parameters again

    From this point, everything worked.
    Before that, I regenerated the attribute lookup table many times and if filter was working when the lookup table was being regenerated, once this job was done, the filter stopped working again.
    With this activation/regeneration/deactivation, everything is fine and stable.

    Maybe that can help you?

    Plugin Support Daniyal Ahmed – a11n

    (@daniyalahmedk)

    Hi there,

    Thanks for reaching out.

    It looks like we need to regenerate the product attributes lookup table. Can you please navigate to WooCommerce > Status > Tools and click on “Regenrate” button as shown in the following screenshot:

    Once done, please try to clear the transients as shown in the following screenshot:

    I hope it helps!

    Best,

    Thread Starter lilcreativedev

    (@lilcreativedev)

    Thank you – that fix works! Website filters back to normal now.

    Much appreciated.

    @daniyalahmedk that solution is only temporary – as rebuilding attribute table is. After few minutes the issue occurs again. Please fix it.

    Plugin Support Igor H woo-hc

    (@ihereira)

    Hi @frafor

    I understand the issue is appearing again on your site, sorry to hear that.

    For us to check further into your case, please be sure to create your own thread:
    https://wordpress.org/support/plugin/woocommerce/#new-topic-0.

    This is to make sure every user receives proper attention.
    * Frequently Asked Questions.

    Thanks for your understanding.

    @ihereira The solution proposed by @madmax4ever is in fact working now! I have left the checkbox in Woocommmerce > Settings > Products tab > Advanced checked during a previous attempt (maybe because I had too many tabs open ^_^)

    • This reply was modified 2 months, 4 weeks ago by frafor.
    Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Hi @frafor

    Glad you found that! Thanks for letting us know.

    Feel free to create a new thread if you have any other questions.

    Cheers

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.