Support » Plugin: TablePress » Filter Bug

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your question, and sorry for the trouble.

    Can you please post a link to the page with the table where this problem happens, so that I can take a direct look? Thanks!

    Regards,
    Tobias

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    could the reason for this simply be that there are some empty rows at the end of your table? Can you please try again after deleting those, on the table’s “Edit” screen?

    Regards,
    Tobias

    You were right, thank you. Lets go for another question: Is there any oportunity to use the collapse mode for just mobile (desktop the normal version)?

    Currently I am using the flip mode for that case but I do not like the horizontal scrolling there..

    Otherwise: Great work!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    no, sorry, that’s not directly possible, due to how the collapse mode works. It only cares about the table and screen widths, but not about the device type (mobile or desktop).

    Regards,
    Tobias

    Okay. Is there any other opportunity to make scrolling in the mobile version vertically with being responsive? (desktop too).?

    Some additional questions:

    1) If I search for a data sheet called m-116 it works fine, if I type in m116, it does not. Is there any way I can manage this?

    2) In my table there is a strange case, where filtering the left section (Part) causes, that the last entry is M-994 and not M-1816. Whats the problem here?

    Thank you for developing this great plugin!

    • This reply was modified 10 months, 1 week ago by trixox.
    • This reply was modified 10 months, 1 week ago by trixox.

    3) Can I modify the entry steps? For Example: Show 20, show 50, show 100? I won’t need “Show 25” for example.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    0) I’m not really sure that I understand that question with the scrolling, can you explain that more?

    1) The searching is exact searching, so M116 is simply different to M-116. If you want to allow both, you’d have to add both into the table. For example, you could add a new second column where you put the part number again with the -, but that column can the be hidden from the visitor with CSS code.

    2) You mean “sorting” hear and not “filtering” right? This is caused by the “M-” in the values. This causes the sorting algorithm to use text sorting and not number sorting. To change this, you could use the TablePress Extension from https://tablepress.org/extensions/datatables-sorting-plugins/

    3) For this, you could add this to the “Custom Commands” text field on the table’s “Edit” screen:

    "lengthMenu": [ 20, 50, 100 ]
    

    Regards,
    Tobias

    Hi,

    1) Could you tell me how to do this exactly? What CSS Code?

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    1) Something like

    .tablepress-id-3 .column-2 {
      display: none;
    }

    (with correct table ID and column number).

    Regards,
    Tobias

    Thanks! Do i need to put that in the plugin css form or in the editor?

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    this goes into the “Custom CSS” text field on the “Plugin Options” screen of TablePress.

    Regards,
    Tobias

    Thanks a lot for your effort..honestly.

    1) Everything worked, besides the sort plugin. I have installed it but did not work in my case (automatically). What do I need to do exactly to make sure, that it is sorted correctly?

    2) “lengthMenu”: [ 20, 50, 100 ] works but it makes the “Show all” disappear (plugin). How can I debug that?

    • This reply was modified 10 months, 1 week ago by trixox.
    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    1) You first need to install and activate that Extension as a plugin. Then, you can add a “Custom Command” (I’ll do that below, because of the other one.)

    2) To add that again, you can modify the existing “Custom Command”.

    In summary, please use:

    "lengthMenu":[[20,50,100,-1],[20,50,100,"All"]], "columnDefs": [ { "type": "formatted-num", "targets": [ 0 ] } ]
    

    Regards,
    Tobias

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Filter Bug’ is closed to new replies.