Support » Plugin: PDF Forms Filler for Contact Form 7 » Fillable PDF Forms NOT attaching to email

  • Resolved brenkworth

    (@brenkworth)


    The Contact Form 7 PDF Form Filler was working perfectly and attaching the PDF form to the email, but then suddenly stopped. I saw there was an issue with an update to the plugin Contact Form 7, so I rolled back to Version 5.3.2, however, I still cannot get the filled in PDF form to attach to the email. I have deleted and re-attached the PDF form, re-mapped the fields, and nothing is working.

    WP Version is 5.6.2.

    Please help.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author maximum.software

    (@maximumsoftware)

    Hi,

    Looks like I’ve botched the previous release (1.3.4). I’ve released version 1.3.5 where I’ve fixed that bug. It should fix your issue.

    Please note that if you have CF7 v5.4, attaching will still not work. Make sure you downgrade CF7 to 5.3.2 and disable any automated updates until I am able to make v5.4 fully compatible and release a new update.

    Let me know if you have any further problems.

    Thanks.

    Thread Starter brenkworth

    (@brenkworth)

    Thanks – I have turned off the automated updates. It is now working. Will wait for your fix.

    Plugin Author maximum.software

    (@maximumsoftware)

    Hi,

    I’ve implemented a fix to allow for CF7 v5.4 support for attachments.

    You can download and try it out at the following URL:
    https://github.com/maximum-software/pdf-forms-for-contact-form-7/archive/b61fa0b1e9ea54ffccd2e8d2771e63cf147ba7ea.zip

    I request users do some testing and let me know if there are any issues.

    Thanks.

    Plugin Author maximum.software

    (@maximumsoftware)

    I’ve deployed a new version. Let me know if you guys have any issues with it.

    There is just one more issue left to fix with CF7 v5.4 support. It is with the download link in submission response message. It shows up as text only right now. I will get that fixed once I come up with an effective solution.

    Plugin Author maximum.software

    (@maximumsoftware)

    I’ve released a new version that fixes the download link feature in CF7 v5.4.

    I have same problem. I did all updates, but still doesn’t working. I had to rollback to:
    – PDF Forms Filler for Contact Form 7 Version 1.3.3
    – Contact Form 7 Version 5.3.1
    – PDF Forms Filler for Contact Form 7 Enterprise Extension Version 1.3.4

    Plugin Author maximum.software

    (@maximumsoftware)

    @ivanjoksimovic, what is the exact reason why it doesn’t work for you? Does it just not attach PDFs to email messages or is there something else?

    By the way, I have just released a new version with some fixes. If your problem was caused by bugs fixed in the latest version, you might be able to get the new version to work. Regardless, if you can tell me exactly what your trouble is, I might be able to fix it.

    Emails coming without attachment, and when user click send, doesn’t get message that form is successfully submitted, it just loads instead.

    Plugin Author maximum.software

    (@maximumsoftware)

    Would it be possible for me to log into your WP instance and debug the issue directly? If you don’t mind it, send me temporary wp-admin login details to admin at maximum dot software and I will take a look at your issues.

    Plugin Author maximum.software

    (@maximumsoftware)

    @ivanjoksimovic, your description of the problem sounds like you are not running the latest version of the plugin. If you want to use CF7 v5.4, you need to update the PDF Forms Filler for CF7 plugin to the latest version (1.3.11). You should not be having the problems you are describing with this new version.

    PDF Forms Filler for CF7 worked fine but after the updates. I just received submission notices. Fillable PDF Forms do not attached.

    I am running WP V5.71, PHP V 7.3.27, CF7 V5.4 and PDF Forms Filler for CF7 plugin V1.3.11 but Fillable PDF Forms do not attached.

    Plugin Author maximum.software

    (@maximumsoftware)

    I am not able to reproduce your issue.

    Can you please make sure you have the following options enabled?
    1. Attach to primary email message
    2. Attach to secondary email message

    Can you also post a list of the currently installed plugins in your WP instance?

    If you don’t mind sending me temporary wp-admin login details over email to admin at maximum dot software then please go ahead and send it. I will log in and try to debug your issue directly.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.