Support » Networking WordPress » Fileupload Url doesn't show up in setting

  • Resolved Daniel

    (@41dreams)


    Hello,
    Having problems with only 1 of my many wordpress multisite subsites. I’m using a plugin called Sermon Browser and it works great on all other subsites except 1 of them. When I try to upload a file using it, it tells me that “Upload is disabled”. I cross referenced the problematic site’s settings with another site where the plugin is working and the only difference I can see is that Fileupload Url is missing and on the site where it is working it shows up.

    I was going to post this question under plugins but I don’t think it has anything to do with the plugin.

    Any Ideas?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    No one seems to be responding on that forum. But I really don’t think it has anything to do with the plugin because it works on all my other multisites (and its the same plugin files). When comparing the settings of a working site everything looks identical until you get down to the “Fileupload Url” on the site where the plugin works it shows “Fileupload Url” and on the site where it doesn’t work it shows “Initial Db Version”. Any Ideas?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Two thoughts.

    Run a repair of your database first.

    If the ‘Fileupload URL’ setting is totally missing, you can add it in via the database (but search the page first, they’re not in order).

    I ran a repair on the database like you suggested and got this message back on a few of the tables:

    “The storage engine for the table doesn’t support r…”

    this error message only occurred on the site that I am having problems with.

    Error showed in:

    wp_7_commentmeta
    wp_7_comments
    wp_7_links
    wp_7_options
    wp_7_postmeta
    wp_7_posts
    wp_7_terms

    …and many others

    Any ideas?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    “The storage engine for the table doesn’t support r…”

    Well… That’d be it.

    Is that MySQL server set to default to InnoDB tables? (Ask your host if you’re not sure)

    I will check with the host today on that. But, isn’t strange that this is only happening on one of the multisites all the others in that database seem to be working great?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Yes, it’s very strange. I’d wonder if some of your tables got flipped over.

    I contacted the host and by default it is set to InnoDB I tried to run ALTER TABLE wp_7_comments ENGINE=INNODB and I got this error:

    “You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ALTER TABLE wp_7_comments ENGINE=INNODB ALTER TABLE ‘ at line 2”

    I also looked at the exported version of the database and noticed that all of these tables already have the “ENGINE = Innodb” assigned after the table is created. So i’m wondering if this is the problem at all..

    Any Ideas?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I’d be grabbing my host, and asking for help why I can’t repair those tables.

    Alright I contacted my host and they said that becuase those table are set to INNODB, the repair function isn’t supported. I converted the INNODB tables to MyISAM using:

    ALTER TABLE wp_7_comments ENGINE = MYISAM;

    and all seemed to go well. I ran a successful repair on all of those tables but the initial problem still exists. (Upload is disabled. Please contact your systems administrator.)

    Any Ideas? You’ve been a great help so far btw!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You’re logged in as Super Admin, right?

    yeap

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Does it work without that plugin?

    I can upload media just fine but I can’t upload any audio using that plugin. I disabled the plugin and in the site’s settings i’m still missing the the file upload field and in it’s place it has the field of “Inital db Version 19470”

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Don’t get worried about the ‘different’ field, they’re not actually in order. That it’s MISSING entirely is the point 😉

    The problem is I don’t know the plugin, and the devs really are who should be saying what the RIGHT field is.

    Was the plugin activated network wide or per site?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Fileupload Url doesn't show up in setting’ is closed to new replies.