Support » Fixing WordPress » Filetype not supported. Thumbnail not created.

  • Tried the latest WP1.1 nightly dated Feb 7. When I tried to upload a jpeg file, it works (except for the image resize). I get this error saying:
    Filetype not supported. Thumbnail not created.
    Yet the image was just a normal .jpg file. Cool feature though — I think a LOT of users would greatly appreciate some sort of way of easily adding images to their blogs, especially after reading the forums (I know I do!).

Viewing 15 replies - 1 through 15 (of 15 total)
  • This has to do with the GD library you have installed with PHP. Newer versions of PHP (greater than 4.3 I believe) should handle everything just fine.

    I’ve created a work around for this here This should support older versions of the GD Library like 1.6 with older PHP builds like 4.2.1

    finally got it to work here.
    the path was to be supplied relative to the admin folder…

    Can you elborate on where to supply the path relative to the admin folder?

    I changed my admin-functions.php to have both of the suggestions mentioned in the thread above and I still cannot get the thumbnail to work. It load the image fine, but gives me the error
    Filetype not supported. Thumbnail not created.
    I am using the new nightly build. I am new to WordPress, so go easy on me. I tried loading a jpg and a gif and get the same error both ways. Does anyone have an idea what might be wrong?

    gifs are not supported by GD, I beleive. you should not have a problem with jpegs though, especially if you are using GD2. The hack mentioned above is only useful if you do not have GD 2. You can find what version of GD your server has by going to the page

    I am using PHP Version 4.3.1. I did not see a listing on the page for GD. This might be due to the fact that I don’t know what it stands for. I tried creating the thumbnails before using the patch above. And before using the patch above I uploaded the wp folder three times to try and see if that was the problem. Can someone tell me where to find the GD version on the script above? Perhaps the problem is that my hosting provider (webhost4life) doesn’t have this part installed?

    Okay. My hosting provider didn’t have GD installed at all. That might explain the problem. However, they installed 1.6.2. They said they would install GD 2 if I gave them a link. Does anyone have a link for GD 2?

    Hmm, I am seeing the same problem with WP 1.2 and php 4.3.7/gd2.
    I decided to rebuild and reinstall and lo, I find that the default configuration of php doesn’t have gd support. I’ll add that and see what happens then.

    That was me posting anonymously above: I did reinstall php and gd2 but no love. I still get no thumbnails.
    On a related note, does anyone know if there are plans to add mt.supportedTextFilters to the API so that clients like ecto can upload images?

    Here is how I got GD2 to work in IIS
    Edit PHP.ini –> go to
    ;Windows Extensions
    Remove the remark semi-colon in front of
    and save.
    Stop and restart your IIS service from your services console.
    If you still have no love…
    Copy php_gd2.dll from your <DRIVE>:/PHP/EXTENSIONS to <DRIVE>:/PHP (or in the same Dir as PHP.EXE)
    Worked for me…. now how to display the thumb and link it to the full sized image…hmmmm

    Addition to my post above:
    When I coppied php_gd2.dll to my <DRIVE>:/PHP dir, I also coppied it to my <DRIVE>:/windows/system32
    dir. Since then I have found that it is this copy (<DRIVE>:/windows/system32/php_gd2.dll ) that seems to be doing the trick.

    Just a note on Windows servers:

    Make sure you copy the file BEFORE changing your PHP.ini

    I made the change to PHP.ini first, then copied the file, and while I was doing it PHP reloaded the .ini file (by itself) and started throwing “cannot find ./php_gd2.dll” errors at me until I installed the file, re-commented the line, then un-commented it again.

    I have also got GD version 2.0.28 installed on Apache 2 and it seems that thumbnails are not been created, although I get no error messages. No clue how to solve this… anyone?

    Solved this problem for my installation now. It was an error in the setup of GD2.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Filetype not supported. Thumbnail not created.’ is closed to new replies.