Filetype not supported. Thumbnail not created. in 1.5 (8 posts)

  1. Arlo
    Posted 10 years ago #

    I'm getting the error "Filetype not supported. Thumbnail not created." when uploading any image type (jpg, gif or png) to my server. I am running on OS X server with Apache 1.3.33, mySQL 3.23.49 and PHP 4.3.10 so my versions are all up to date. Ideas?


  2. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Check your support filetypes in Options/Miscellaneous.

  3. Arlo
    Posted 10 years ago #

    They're fine, it's the default "jpg jpeg gif png"
    What else could be wrong?

  4. Arlo
    Posted 10 years ago #

    Nevermind, I fixed it; turns out GD wasn't installed on my server at all (despite what PHP 4 docs said :P). I upgraded to PHP5, all is good.

  5. almodo
    Posted 10 years ago #

    Same Problem here. What is "GD" ?

  6. Anonymous
    Posted 10 years ago #


    It's a program that allows WordPress to modify images. ImageMagick is another program that does this (but WP doesn't support it).

  7. almodo
    Posted 10 years ago #

    @mark: Thanks for the information.

    Well i have a Debian testing installation with:
    ( phpinfo() )

    PHP Version 4.3.10-16

    GD Support enabled
    GD Version 2.0 or higher
    FreeType Support enabled
    FreeType Linkage with freetype
    T1Lib Support enabled
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled

    SO i have all the needed Files. But the Problem still exits. I have no idea... And yes: I restartet the apache server

    Maybe it would be a good idea make wordpress supporting "convert" from ImageMagick

  8. toomanydogs
    Posted 10 years ago #

    I solved this problem for debian stable (woody).

    Here is my recipe:

    Login on your server as root
    Install the php4-gd2 liberay. You really need the GD v2 version php4-gd doesn't work
    Restart apache

    So this is what you do.

    {type your root password}
    >apt-get install php4-gd2
    >apachectl graceful

    The installer will ask you if you would like to add soem to a ini file just answer yes and you are fine.

    Have fun

Topic Closed

This topic has been closed to new replies.

About this Topic