Support » Plugin: Redis Object Cache » Filesystem Not Initialized

  • Resolved zephyr91

    (@zephyr91)


    Hi,

    I have a different error from the “usual”, if anyone knows what it could be apart from basics (in advance).

    So the error is “Filesystem could not be initialized”, as per the plugin main page validation, and checking diagnostic it shows the same error.

    # main page
    Status: Conectado
    Drop-in: Válido
    Sistema de arquivos: Sem permissão de escrita

    # Diagnostic
    Filesystem: Não foi possível inicializar o sistema de arquivos.

    the message is translated to portuguese, but in english it would be what I mentioned. Now to what I validated already and the current behavior.

    1- Redis is installed and connected (as you can see what I pasted before)
    2- WP is writing data to Redis: db0:keys=12548,expires=266,avg_ttl=37155160157
    3- My website has application user (meaning not www-data), but both have access to the folder, as object-cache.php is copied and removed if I enable/disable the plugin.
    4- I tried enabling WP errors logs for troubleshooting, but for some reason it is not even printing to my apache error.log but also not even creating a new log file (same as the example from WP debugging codex)
    5- I have metrics in the plugin, meaning it is working (I guess).

    I checked the code for the class-pluging.php and the documentation and it is a simple call to the O.S, but if it didn’t had permissions or anything it wouldn’t even copy object-cache.php… so how can I troubleshoot this?

    Thanks a lot in advance.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Sounds like PHP can’t write to /wp-content/object-cache.php.

    Thread Starter zephyr91

    (@zephyr91)

    Current permissions aer “-rw-r–r– 1 appuser appuser 95143 Nov 11 12:44 object-cache.php”

    if WP is trying to use through www-data then its probably the case, I’ll attempt here to change it to 664 and see if it works.

    Thanks

    #Edit
    It didn’t work, tried 664, 666, 777. what else could I try, because if its no writing to the file then its not working properly. Any other attempt I could do?

    • This reply was modified 3 weeks, 2 days ago by zephyr91.
    Thread Starter zephyr91

    (@zephyr91)

    Any other ideas?

    Thread Starter zephyr91

    (@zephyr91)

    Any other ideas?

    # Edit

    I tried also changing ownership of the file and gave direct permission to www-data user, which is apache2 user, to write into the folder.

    I used the “query monitor” plugin to find php errors that were supressed, but I didn’t find any for this one.

    Plugin Author Till Krüss

    (@tillkruess)

    Actually, I think the test file is WP_CONTENT_DIR . '/.redis-write-test.tmp', and not object-cache.php.

    You can either ignore the warning, or give WordPress proper write permissions to wp-content.

    Thread Starter zephyr91

    (@zephyr91)

    My concern is if the plugin is not working properly, because the “cache object” is not changing the timestamp, and I don’t know if its expected to change or not… Is there a way to for the test call?

    I even tried creating the file with all the permissions there.

    -rwxrwxr-x 1 www-data appuser 0 Nov 12 18:55 .redis-write-test.tmp

    but the result in the admin page is still the same

    Plugin Author Till Krüss

    (@tillkruess)

    I can’t help you with file permissions. Make sure WordPress can write to wp-content.

    Thread Starter zephyr91

    (@zephyr91)

    But that is where the weird part is… the permissions are right. I enabled a shell for www-data and logged in with it and touched a test file.

    www-data@dipanopaulista:~/html/dipanopaulista/wpdipano/wp-content$ touch test_content
    www-data@dipanopaulista:~/html/dipanopaulista/wpdipano/wp-content$ ls -l
    total 124
    drwxr-xr-x  3 dipano   dipano    4096 Nov  9 03:13 customization
    -rw-r--r--  1 dipano   dipano      28 Jan  8  2012 index.php
    drwxr-xr-x  4 dipano   dipano    4096 Nov 11 17:50 languages
    -rwxrwxr-x  1 www-data dipano   95143 Nov 12 15:57 object-cache.php
    drwxr-xr-x 26 dipano   dipano    4096 Nov 11 17:51 plugins
    -rw-r--r--  1 www-data www-data     0 Nov 13 14:19 test_content
    drwxr-xr-x  6 dipano   dipano    4096 Nov  9 02:08 themes
    drwxr-xr-x  2 dipano   dipano    4096 Nov 11 17:51 upgrade
    drwxrwxr-x 16 dipano   dipano    4096 Nov 12 04:10 uploads
    www-data@dipanopaulista:~/html/dipanopaulista/wpdipano/wp-content$

    The only folder that is writable is the wp-content, the wp-admin and the wp-include aren’t.

    Plugin Author Till Krüss

    (@tillkruess)

    I can’t help you with server file permissions, ask on Stack Overflow. It works for everyone else.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.