Support » Plugin: Contact Form 7 » Files not attached to emails

  • Resolved Agence Myso

    (@agence-myso)


    Hello,

    I have been using Contact Form 7 for years now and never had to ask for help.
    But I have been struggling with this for hours now and I really cannot do more…
    I receive emails, but files are not attached. I tried to change tag name, ftp permissions, I tried to create a new contact form, new fields, etc., nothing works. I even tried to download Drag and Drop multiple files plugin. I never received any file attached to my emails.
    Just to be clear : yes, I put the correct tag in the “attached files” field under the “mail” tab. I have configured contact forms like 100 times before.
    Has anyone ever had a problem with his/her domain provider related to Contact Form 7 ?
    I really never had any problem, I am looking for any kind of solution…
    Thank you !

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter Agence Myso

    (@agence-myso)

    I just found that the problem will not occur with every mail address. If I put a Gmail address as receiver (in the admin), attachments are not included in the emails. If I put an email address from my own domain, it works…
    Anyone already noticed that ?

    • This reply was modified 2 months, 2 weeks ago by Agence Myso.
    • This reply was modified 2 months, 2 weeks ago by Agence Myso.
    Plugin Author Takayuki Miyoshi

    (@takayukister)

    See Setting up mail

    What email settings do you have in the Mail tab panel?

    To protect personal data, hiding email addresses in the settings or replacing them with dummy addresses is strongly advised. You can also include screenshots.

    Thread Starter Agence Myso

    (@agence-myso)

    Hello Takayuki and thank you for responding.

    The mail settings are ok. I found that the form works with most adresses but not for example with mine. This is so weird… I just do not receive attachments on my Gmail address. But if I put the Gmail address of my girlfriend, it works đŸ˜±.
    And if I put my professional address, it works as well.
    For the moment being, my client started again to receive attachments so it’s ok. But I would love to understand what’s happening with my Gmail address…

    • This reply was modified 2 months, 2 weeks ago by Agence Myso.
    Thread Starter Agence Myso

    (@agence-myso)

    Hello again,

    After some weeks I must say that the problem is still there and really annoying. Sometimes files are sent, sometimes not. I have an ID displayed in Flamingo, which testifies that something was attached, but the file is most of the time missing in the mail. But not all the time. And I cannot see any coherence.
    Please give me some feedback, because I cannot see any solution from my point of view…

    Thank you for your help.

    Thread Starter Agence Myso

    (@agence-myso)

    In case someone ever come to this page. I found the key to solve this mystery.
    I am using Mailpoet to send newsletters. If you pay attention very carefully to the options, you will find one which proposes to have Mailpoet taking care of all the mails sent by the site. DO NOT USE THIS OPTION. It is getting rid of the mail attached files, even if they come from another plugin, as WPCF7.
    SO this is it. Everything works fine now. I only lost 8 hours in my life 😓.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.