Support » Fixing WordPress » Files keep going missing

  • For some reason, my theme files and images associated with articles keep going missing. This is the second week in a row that this has happened. Does anyone have any idea on why this is happening? Timthumb?

    Any ideas would be most helpful, as I have to go back and manually reupload my theme and all the images…

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Sorry

    wordpress 3.2.1

    Website climberism.com

    esmi

    (@esmi)

    Forum Moderator

    Are you using the latest version of Timthumb?

    I do not have any problem browsing your website page to page is working fine.

    I just re-uploaded the site, but now the images are all broken because they have been deleted.

    @esmi could timthumb do something like this? I am not sure if it’s the latest timbthumb, is there a way to check?

    Last week and this week, the same thing happened and the same (exact) files went missing. I don’t really know what to do to stop it from happening next week…

    esmi

    (@esmi)

    Forum Moderator

    could timthumb do something like this?

    It could account for missing images, yes. What is far more worrying is that, if you don’t have the latest version of timthumb, then you’ve left your site wide open to hacking. Older versions have a security hole.

    The only timthumb I can find is in my theme’s script folder.

    Could timthumb delete theme files as well?

    My other questions is why is it targeting my theme files and images and not any other files?

    I am trying to rule out any other thing that might be causing the issue.

    esmi

    (@esmi)

    Forum Moderator

    Could timthumb delete theme files as well?

    Not in itself but it could allow access to a hacker who could delete files.

    Thanks esmi,

    So I am trying to get the latest timthumb (version 2.8.2) from here : http://www.wpzoom.com/forum/viewtopic.php?f=21&t=5080

    Everytime I replace the old timthumb with the new version of timthumb, my images break on the site. I have changed the permissions to writable but still no luck getting the images to show back up.

    ok looks like I got it, the permissions were 755 and looks like it needs to be 777

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Files keep going missing’ is closed to new replies.