Support » Plugin: Loco Translate » files from custom location are ignored

  • Resolved bg17aw

    (@bg17aw)


    If I use the recommended “custom location”, files are ignored.

    If I copy the .po and .mo files to the classic location (languages\plugins) everything works fine.

    Any idea why?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Tim W

    (@timwhitlock)

    Assuming Loco Translate is enabled – the success of this depends how the plugin loads its translation files. If it loads them too early or uses the wrong WordPress functions then Loco’s load helper can’t work.

    Please post a link to the plugin source code and I’ll tell you why it’s not working.

    Hello,

    The plugin is https://wordpress.org/plugins/realia/developers/

    I think you can see the code in SVN

    Let me know if this info is not enough and I’ll try contacting the authors

    Plugin Author Tim W

    (@timwhitlock)

    The Realia plugin loads its translation files too early. It doesn’t wait for other plugins to be loaded, so Loco’s filters can’t run in time.

    You’ll have to store your files in the system languages folder for them to load. This is only safe if you have auto-updates disabled.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘files from custom location are ignored’ is closed to new replies.