Support » Plugin: WP-Filebase Download Manager » Files are not loading in Tree

  • Hi,
    I’m managing a website for an association of medicine students and i discovered your plugins.
    It was perfectly working the first time, but now files can’t load in tree view. Folders are shown but the loading icon is always running when it tries to show files.

    I think it’s an Ajax problem.

    But i don’t really know how i could fix this.

    Could you please give me some advices.
    Thx

    Here you can see a test page of our website, where the Tree doesn’t work properly : http://www.cmcluj.com/?page_id=18

    http://wordpress.org/extend/plugins/wp-filebase/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I’m having the same problem. Just updated to the latest Filebase.

    It worked very well until the latest update.

    The file list works correctly, but the loading icon in Tree view just keeps spinning. I’ve tried deactivating plugins, but to no avail.

    Any ideas? Anyone?

    Plugin Author Fabian

    (@fabifott)

    Please post the URL of your site.

    Right. I’m having that File Tree issue on two sites.

    http://arrowsmithlodge.ca/that-file-thing-test/

    and

    http://jrpc.org/francis-file-view-test/

    I have loaded the File List view on the Downloads page for both sites and that works fine.

    Some strange fact,

    It seems it’s perfectly working if we use Firefox.
    But on Internet Explorer, Chrome or Safari, it doesn’t work.

    I don’t understand why, but it’s like that.
    Maybe java script fails with IE, Chrome and Safari.
    But strangely, Firefox loads the files and folders perfectly…

    I can’t get the Tree View to load in Firefox, Chrome or Opera. The necessary scripts are loading.

    I did make some alterations to my functions, so I’m going to delete those changes and see what happens.

    Plugin Author Fabian

    (@fabifott)

    Francis Penny, jQuery is not loaded on your blog. Disable any CDN/jQuery Plugins, its not WP-Filebase.

    CorpoCluj, it seems you have at least one plugin installed that produces invalid line breaks on every page. Take a look at your pages source. Disable other plugins, again thats not WP-Filebase fault.

    Solved!!

    Hi. Thanks for the speedy response.

    Deleted one addition to my functions.php and all is well. It had to do with enqueue scripts. Screwed up in some way. No matter. Everything works fine.

    Hi,
    The file browser is not loading the files inside a folder, it just spins. Any help is appreciated.
    here is the link
    http://bolderimage.d211.org/students/forms/
    i installed wp-filebase version is 0.2.9.24.

    To troubleshoot file tree problems, try the following

    1)Backup your WP-database and WP Directory (if needed)
    2)Disable all plugins
    3)Go to Dashboard -> Updates ->Reinstall-Now (This will reinstall WP core files)
    4)Now test out WP-Filebase File Browser and it will load.
    5)Enable one plugin at a time and test it out

    *Experience
    I had similar problem.The file browser did not work and also when i am adding a file, the post ID did not work.I had some Ajax errors. Just disabling all plugins except WP-filebase did not solve for me initially and this made me believe the problem was not caused by other plugins. Only after disabling all plugins and then reinstalling WP core files (step 3 as above) it solved my problem. Since i did not believe the problem was caused by other plugins, i reactivated them and the problem came back a day later after i activated the plugins as if there was some cron job running once a day!

    Conclusion
    After reinstalling core files, the File browser worked well. So it means, WP-Filebase works well as long as WP files are in original state. It also means another plugin should be the culprit. Eventually i found my culprit! The plugin WP-Better Minify was the cause. Disable and uninstall the plugin and reinstall WP core files once more solved the problem once an for all…

    Good luck

    on a MU site with custom domain mapping, the ajax tree is not getting the permissions correctly and in turn not displaying the files.

    /wp-content/plugins/wp-filebase/wpfb-ajax.php is not properly authenticating and returning the file list result. This is because i have a subdomain MU installation with a domain mapping plugin running as well.

    Filebase is trying to load:

    http://customdomain.mainsite.com/wp-content/plugins/wp-filebase/wpfb-ajax.php

    instead of:

    http://customdomain.com/wp-content/plugins/wp-filebase/wpfb-ajax.php

    im going to go through the plugin and fix it for my site. however i would hope you can add this fix to the next release. If you’re able to fix it before i can please post the code changes here 🙂 and when i find a fix i will post here as well.

    thanks! awesome plugin

    update:

    not too hard of a fix.. in wp-filebase.php change:

    define(‘WPFB_PLUGIN_URI’, str_replace(str_replace(‘\\’,’/’,ABSPATH),get_option(‘siteurl’).’/’,WPFB_PLUGIN_ROOT));

    to:

    define(‘WPFB_PLUGIN_URI’, str_replace(str_replace(‘\\’,’/’,ABSPATH),’/’,WPFB_PLUGIN_ROOT));

    that will fix tree view errors for people using multisite with custom domain mapping

    thanks!

    updates: as for me the problem persisted…so as a work around i have set up a cron job to reinstall WP corefiles on hourly basis…so far this seems to solve the problem i was having. Cheers

    Zoltan

    (@horvathzoliinfo)

    Hi! I noticed that since I installed the latest version of the WP-filebase, the tree-view doesn’t work. Than, I turn off the Visual Form Builder and the tree-view works again.
    Is there any way to fix the problem and make both plug-ins working?

    I can’t get this to work either despite following the above advice. Any help gratefully received please. Url is:

    Shared documents

    does anyone know why it works on my desktop computer but not my iphone? The spinning thing keeps on spinnin 🙁

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Files are not loading in Tree’ is closed to new replies.