WordPress.org

Forums

File Uploading problem with WordPress 3.1 MU (17 posts)

  1. FeldonKTH
    Member
    Posted 4 years ago #

    Hi,

    Really been trying to find an answer in all the forums but can't find the issue resolved in a way which I can copy.

    I'm running a windows based machine for development and got Apache as a webserver.

    My problem is that whenever I upload a file/image in WordPress the file ends up unreadable. When I go into the folder the file is there but I don't have permissions to read it. I can surf to through a browser if I go directly to the blogs.dir/#/files/date/-path and not to the /files/ path.

    The usual question seems to be to get to see the .htaccess-file so here it is:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.*) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    I'm also running Domain Mapping but has done a clean installation without it and still got the issue. Also I'm running sites on subdomains if that helps.

    Since I got the site on my local machine you'd need to hack your hosts-file to see it and I really don't like giving out access to it.

    Is this something that will solve itself once I get it up on to the proper host that is running *nix-enviroment?

  2. I can surf to through a browser if I go directly to the blogs.dir/#/files/date/-path and not to the /files/ path.

    That generally means your httpd.conf isn't set up right.

    What do you have set for AllowOverride ?

  3. FeldonKTH
    Member
    Posted 4 years ago #

    It's set to none

  4. FeldonKTH
    Member
    Posted 4 years ago #

    Tried changing the AllowOverride-option and it generated 500 Internal Server Errors

  5. FeldonKTH
    Member
    Posted 4 years ago #

    Oh and this is only a problem for all the other sites. The main/primary site works fine.

  6. AllowOverride FileInfo Options

  7. FeldonKTH
    Member
    Posted 4 years ago #

    When I do that all I get is internal server error =(
    This is how it looks in my httpd.conf at the moment:

    <Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs">
        #
        # Possible values for the Options directive are "None", "All",
        # or any combination of:
        #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
        #
        # Note that "MultiViews" must be named *explicitly* --- "Options All"
        # doesn't give it to you.
        #
        # The Options directive is both complicated and important.  Please see
        # http://httpd.apache.org/docs/2.2/mod/core.html#options
        # for more information.
        #
        Options Indexes FollowSymLinks
    
        #
        # AllowOverride controls what directives may be placed in .htaccess files.
        # It can be "All", "None", or any combination of the keywords:
        #   Options FileInfo AuthConfig Limit
        #
        AllowOverride FileInfo Options
    
        #
        # Controls who can get stuff from this server.
        #
        Order allow,deny
        Allow from all
    
    </Directory>
  8. then change options to All.

  9. FeldonKTH
    Member
    Posted 4 years ago #

    That resultated in yet another Internal Server Error =/

  10. Then talk to your host.

  11. Just to make sure ... try this:

    Options Indexes FollowSymLinks MultiViews

    and

    AllowOverride All

  12. FeldonKTH
    Member
    Posted 4 years ago #

    Andrea... thanks... however that would be me... sitting on my home computer..

    Ipstenu... thanks but that just resulted in an Internal Server Error
    [Mon Feb 28 21:03:20 2011] [alert] [client 127.0.0.1] C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/naprapaterna/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
    And the .htaccess file you see above... =/

    Guess I'll have to bring the stuff live on the actual hosting-machine online and hope they got a better idea on how to set things up...

  13. Last guess is this (I hate Windows and Apache... Grrr).

    <Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs">
        #
        # Possible values for the Options directive are "None", "All",
        # or any combination of:
        #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
        #
        # Note that "MultiViews" must be named *explicitly* --- "Options All"
        # doesn't give it to you.
        #
        # The Options directive is both complicated and important.  Please see
        # http://httpd.apache.org/docs/2.2/mod/core.html#options
        # for more information.
        #
        Options All
    
        #
        # AllowOverride controls what directives may be placed in .htaccess files.
        # It can be "All", "None", or any combination of the keywords:
        #   Options FileInfo AuthConfig Limit
        #
        AllowOverride All
    
        #
        # Controls who can get stuff from this server.
        #
        Order allow,deny
        Allow from all
    
    </Directory>
  14. FeldonKTH
    Member
    Posted 4 years ago #

    Thanks... yeah windows seems to be a bad idea but since I'm doing everything on a single machine and I'm a gamer at heart Windows is the only real system I can run...

    The guess however ended me with a 500 internal server error... I'm guessing the "safety" that's built into win 7 really fucks everything up... =/

    Going to take down current sites and go live blindly ^^

  15. alishiraz89
    Member
    Posted 4 years ago #

    I was facing the same issue and then figured out that the problem was due to a plugin called wp-smushit and after deactivating that uploading starts working as normal

  16. FeldonKTH
    Member
    Posted 4 years ago #

    Ok thanks but I was only running MU Domain Mapping and SEO all in one as plugins.

    Everything I've tested leads me to believe that windows 7 is a retarded system that has serious issues with letting people having permissions to things. The files I uploaded wasn't even readable by the administrator of windows and I had to give admin password every time I wanted to delete the files. So basicly just make sure you're not running windows vista or 7 for this since those OSs got permission issues and you need to be freaking rocket scientist to solve them =/

    All my problems vanished when I took the site live on the clients host who runs a linux/unix-machine with everything configured correctly.

  17. makapu
    Member
    Posted 4 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic