Support » Fixing WordPress » File uploader stalls, then crashes server.

  • I use WordPress 3.3.1 on a site hosted at GoDaddy ( and since yesterday, I’ve been having issues with the file uploader.

    When attempting to upload photos for our posts, the progress bar will show the file as partially complete, and sometimes it even get to “crunching,” but the file doesn’t upload (see screenshot).

    Each time this happens, the server appears to crash, and for about 3-5 minutes I cannot access any content on our site.

    I’ve tried changing file names, changing file sizes, uploading with a different browser, uploading from a different computer, and clearing my browser cache, but none of these things seem to help.

    This is the first time I’ve ever had any problems with WordPress, but as our site makes heavy use of photos, this is already becoming a huge issue. Any help is appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You may want to check the data credentials with your hosting provider.

    At the risk of sounding woefully ignorant – what exactly does that mean?



    Forum Moderator

    Have you tried checking your server’s error logs for clues?

    Just did that – no error logs are available.



    Forum Moderator

    Why? Many hosts do provide access to errors logs one way or another. Otherwise, how can anyone troubleshoot issues?

    Error logs hadn’t been enabled. Now that they are, I’m trying to recreate the issue.

    Checked error logs – there are several logs from earlier today, but they’re all blank.

    Also sent a Support Ticket to my hosting provider – here’s what I received in reply:

    Thank you for contacting Online Support. I would be happy to see why you are having an issue with upload in WordPress. To fix the issue with WordPress, you will need to disable FastCGI.

    To Disable FastCGI for PHP on Your Linux Shared Hosting Account
    1. Log in to your Account Manager.
    2. Click the Products tab, then click Web Hosting.
    3. Next to the hosting account you want to modify, click Launch.
    4. In the Settings section of the Hosting Control Center, click the File Extension icon.
    5. Click edit icon to the right of .php and .php5.
    6. Select PHP version without FastCGI.
    7. Click OK to save your changes.

    Unfortunately, this solution didn’t work. After making the recommended changes, I went back and tried to upload the .jpg files from the previous attempt, and encountered the same issue.

    Same issue for me on GoDaddy as well. Tried your above solution but didn’t change. This is a brand new account and I have other accounts on GoDaddy which work fine with the uploader, I’ve tried everything I can think of and find on the net so far and nothing makes any difference. I’m going to contact GD tomorrow regarding above reply and if I find out anything I’ll post back. This is crazy.

    My ecommerce site is hosted on BlueHost and I noticed a severe slowdown and then lockup when I’m updating former posts that are now Articles.

    Bluehost said I’m using too much CPU resources and throttled down the site severely. It only happens when I use the back end of WordPress not the site itself.

    What could be the cause of this and how can I get rid of it. I didn’t have the problem with the older version of WordPress.

    Ask BlueHost for tips to optimize your site. If your admin section is going slow, it’s usually because you have a plugin or theme that’s adding some feature to the dashboard that is causing problems, or because you have a plugin or theme that is referencing some external resource which may be down or having problems.

    Try disabling plugins/themes and see if things speed up.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘File uploader stalls, then crashes server.’ is closed to new replies.