Support » Fixing WordPress » File upload problems

  • Resolved Bill Dennen

    (@wjdennen)


    I just set up WP 2.0 and everything is going fine, except for file uploads. No matter which image I pick to upload, I get an error:

    “File is empty. Please upload something more substantial.”

    Any ideas?

    Thanks-
    Bill

Viewing 6 replies - 1 through 6 (of 6 total)
  • Try a different browser. I think WP is using whatever the browser claims as the file size when it gives that error.

    Thanks for the reply. I tried Safari, Firefox, and Opera, and all give the same result. There is nothing in my apache error_log that indicates a problem. This is very puzzling.

    Note to self: it helps if file_uploads are on.

    D’oh.

    So how do you turn on the file_uploads?

    I’m having the same problem myself with importing an rss file.

    I’m having this issue on one server with a new install.. uploads work like a charm on my other server. Any leads on this?

    Permissions are wide open, but “File is empty. Please upload something more substantial.” is still a constant companion.

    Yay! This solved my problem too, once I figured out what wjdennen was talking about.

    The site’s PHP.ini had file_uploads set to OFF.

    D’oh indeed!

    ps: You can check your site’s setting with a quick <? phpinfo() ?>. I created a new page with just that command.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘File upload problems’ is closed to new replies.