Support » Fixing WordPress » File upload is not happening

  • Regardless of whether I use the new uploader or the Browse and Upload function nothing uploads. I get the following:

    ..//wp-content/uploads/2012/02. Is its parent directory writable by the server?

    The directories are writeable. I’ve uploaded files previously.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Use FTP to create this folder and verify safe permissions for the uploads folder and it’s subs.

    Hi,

    Thanks for the response.

    I’ve tried that it still does not work. The file permission is 755 Read/Write/Execute for owner I even changed it to 777 and still no luck.

    The folder does not even show up in the in the Media Library.

    Neither does the folders and files I uploaded months ago…

    <Bump>

    Really need to get this sorted.

    esmi

    (@esmi)

    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

    Hi esmi. Thanks for the response. Unfortunately none of that worked. Any other suggestions?

    <Bump>

    Still need to get this sorted…

    Well I got it sorted.

    Dreamhost, when installing wordpress, defaults the “Store upload folder” under “Media Settings” to:- /home/server/dreamhost_user/domain/wp-content/uploads

    This caused the permission problem and the user is unable to use wordpress to upload media.

    The problem is solved by changing it to just:- wp-content/uploads which, coincidently is the default location by wordpress

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘File upload is not happening’ is closed to new replies.