WordPress.org

Forums

File Upload Folder Error (17 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    Hello, I just installed

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    What's gone wrong ? And with what ?

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    woops, let me continue that..
    Hello, I just installed WP 1.2 and everything seems fine except when I click the Upload button on the Control
    Panel. It gives me this message:
    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/home/balandra/public_html/catsudon/wp-content) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.
    I went ahead and did a chmod 777 on this folder and retried clicking the Upload button and it still gave me the same message. Sorry if this may have been discussed in an earlier post but I can't seem to find it anywhere.
    Thank you very much!

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    I'd not use the wp-content folder for storing your images - you may inadvertently overwrite it at a later date through an upgrade.
    Create another new folder ('pictures' for instance), CHMOD that to 777, and then see how you go ?

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    i did the same thing earlier, before using the folder wp-content (i only used it because it said it was
    recommended) i had created an 'images' folder which was also CHMOD 777. and still no go.
    help?

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    worked like a charm! :)

  7. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Good Stuff !

  8. regina
    Member
    Posted 10 years ago #

    oohhh.. *takes the zip and makes a break for it* lol. useful script.

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    thanks podz! i never have to think why wordpress is so much better than mt! :)

  10. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Yup - damned good, and I have *no* idea where I found it. All I do know is that it was freeware.
    Mind you, any copyright notice in there would bloat it *hugely* :D

  11. lutzi
    Member
    Posted 10 years ago #

    Hello, i just upgraded to WP 1.2 on a IIS Machine and it seems all works fine except the setting for the upload folder. When i type in the backslash ( e.g: X:\myfiles\blogpics) and hit the update button WP shows me "X:myfilesblogpics" so it seems WP does not recognise the backslash ? Should i also use the tool what i see before ?

  12. Mark (podz)
    Support Maven
    Posted 10 years ago #

    You could give it a whirl, or ry forward slashes instead ?

  13. lutzi
    Member
    Posted 10 years ago #

    Yep, forward slashes works. Thanks !

  14. witchy
    Member
    Posted 10 years ago #

    LOL well, podz, it seems to be working with every one else but me... maybe I'll change the path from the wp-content, to the actual folder that I have the images in.
    :) thanks for being patient with me, I see from this thread, that you've been answering the same question over and over again.

  15. witchy
    Member
    Posted 10 years ago #

    nope, that didn't work either. what IS the permissions suppose to be? (besides, I want the wp-content to work, because I want to be able to use plug-ins)

  16. Mark (podz)
    Support Maven
    Posted 10 years ago #

    You do not need any permissions at all on wp-content for plug-ins to work. Honest.
    The permission - try 755, 766, 777.

  17. witchy
    Member
    Posted 10 years ago #

    AH! 766 worked! :) I know (the changing permissions) that's what confused me so much, and one of the reasons I like WP so much, because you Don't have to change any permissions.
    Thank YOU Podz!! You're patience with me will be rewarded :) May the bluebird of happiness always be with you :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.