WordPress.org

Support

Support » How-To and Troubleshooting » file upload feature-not writable

file upload feature-not writable

  • hello,
    I’m may be missing where any info about this is on the forum, so I aplogize for bringing it up again.
    I’m trying to get the wp-photos working, (which I’ll have questions about that later… like where’s the upload php file? and do I even need it, with the new 1.2 upgrade and upload button? 🙂
    I noticed that when I clicked on the upload button, that I’m getting this..
    It doesn’t look like you can use the file upload feature at this time because the directory you have specified (/home/witchy/public_html/dei/wp-content) doesn’t appear to be writable by WordPress. Check the permissions on the directory and for typos.
    Now I went to the options/miscellaneous, and made sure that the file upload radio button was checked, and I also used the recommended destination/URI. but I still have that comment, when I go to the upload page.
    What permissions should I give this folder? 777? 666? 755? or do I have a path wrong?
    Any help would be appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thanks for the answer, but that is the absolute path, (even though, just in case, me being a space cadet and all, I did download and upload to the dei folder, to check 🙂 and it is.
    I also do have the images in a different folder. In fact, I’ve put them in an ‘image’ folder, plus I did as the read me file in the wp-photos said to do, and created a wp-photo folder, (with the t folder inside of it, With the thumbnails that I’ve already created off line.)
    But this doesn’t help me, with why the wp-content folder is not writable.
    Any ideas about that?

    Mark (podz)
    Support Maven

    @podz

    So long as the folders that you want your images to go in are writable, then all is okay.
    If you are not going to use wp-content, then it’s permissions are moot.

    Sorry to be dumb. but then, How do I get the photo hack to work?

    ok, just in case any one searches this forum for a problem with the upload/wp-content no permissions 🙂
    Podz was able to help me, it Was confusing, because usually, you don’t have to change permissions with WP (great thing about WP! 🙂
    but it turns out, that the wp-content folder, Did need to be changed to 766 (at least for me). Once that was done, it seems to be working great 🙂
    (thanks again to Podz for your patience)

    Mark (podz)
    Support Maven

    @podz

    Glad it’s all working now 🙂

    Hi — I’m getting the same error message when trying to upload a new theme.
    I don’t have the choice with my host to use 766 — any other suggestions?
    It’s a new install of WP 1.01.1 (?), but I’ve already tried uninstalling and reinstalling. I don’t know much about how to do these things — but can change permissions. I think I’ve tried them all and nothing allows me to upload.
    Anybody have any ideas?
    Thanks, Lissmiller

    Samuel B
    Participant

    @samboll

    @ lissmiller:
    “It’s a new install of WP 1.01.1 (?)”

    I certainly hope not as we’re up to v2.0.5 :>)

    Your host won’t let you chmod to 777?
    chmod 755 works on almost all servers and is safer.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘file upload feature-not writable’ is closed to new replies.