Support » How-To and Troubleshooting » [Resolved] File Upload Error After Upgrading to 3.3

[Resolved] File Upload Error After Upgrading to 3.3

  • Hello,

    I am receiving the following error while trying to add a featured image after upgrading to 3.3:

    “pic1.jpg” has failed to upload due to an error
    The uploaded file could not be moved to C:\inetpub\wwwroot\blog/wp-content/uploads/2011/12.

    I’m running Windows Server 2008 R2. Normally I understand that this message tends to be related to permission issues on the PHP temp folder or the wp-content/uploads folder. I have not changed permissions on either of these folders in a long time, and it has been working fine up until the upgrade.

    Any thoughts or ideas I might be able to try? I’m baffled since no user permissions changed on the folders.


Viewing 15 replies - 1 through 15 (of 41 total)
  • Moderator keesiemeijer


    Did you do a manual or automatic upgrade?
    Check if the permissions are correct on your server: http://codex.wordpress.org/Changing_File_Permissions


    i’m having the same issue. i did a manual update and since the update, i can no longer upload media. i didn’t change any of the folder permissions!

    Is this the first time you’ve tried to upload a file in December?

    nope, there are plenty of files in 2011/12/

    @keesiemeijer – I performed a manual update just like I normally do for all releases. I was updating from the latest 3.2.x version. I triple checked file permissions to verify that they were correct, and as I said before I haven’t changed them since I setup the blog.

    @ipstenu – like madvibes, I also have plenty of files in my wp-content/uploads/2011/12 folder, and file uploading was working fine the day before I performed the upgrade to 3.3.

    I fired up Procmon to take a look at what might be happening when I do a file upload and I’m seeing some references to a possible buffer overflow:

    Procmon Screen Capture

    That is what Procmon shows while I’m trying to upload a featured image. This is after I give full permissions to the Everyone user on both the PHP temp folder and the /wp-content/uploads folder.

    I’ve double checked the php.ini file to ensure larger files are allowed to be uploaded, and I have upload_max_filesize = 2M. I’ve also checked the web.config that IIS is using and it has maxRequestLength configured to 4096 (4 MB). The file I’m uploading is somewhere in the 70 KB range, so I know that’s not the issue.

    I’ve also tried the standard file upload as opposed to the new fancy upload and I get the same result.

    Any help is appreciated! I have to think it’s a problem with the new code since nothing has changed on my end, but I guess that is yet to be determined.


    i had my network admin check that my user has all the permissions from the root level to write to folders. i should be able to do anything at this point, but still can’t upload files.

    @rkrause – have you been able to make anything work?

    @madvibes – Nope, I still have not been able to get it working. I’ve tried disabling all of my plugins and still have the same error. The only thing I have not tried is applying the standard Twenty Eleven theme to see if it could be a theme incompatability. Beyond that, I don’t know where to go from there.

    Anyone else have any trouble with this? Or any other suggestions?


    i’m pretty sure it has to do with wordpress changing group and user permissions when it’s installed.

    How does WordPress change permissions when it is installed? Doing the manual installation, I just copy files from one directory to another…there is no installer or anything like that which would modify directory permissions. Also, since I checked the permissions on both of the upload folders in question, I’m not convinced that the web server and PHP processes do not have appropriate access to the resources they need.

    I had the same problems and ended up rolling back to the version I was on before, 3.2.1. I’m not sure what the deal was because I had full privileges. I think it has something to do with the new uploader code in this release.



    I had the same problems and ended up rolling back to 3.2.1. It happened on a WP istallation running on Win2003 server (IIS with latest php) as well as on a dev installation running on Win7Pro (with the latest php, as well).

    The win2003 server installation had also problems giving me a working upload button – I had to use the alternative provided although at the end it also failed to upload the file.

    To make thinks worst, another WP installation running on win7/IIS/latest php works fine with 3.3.

    All PCs have WP on IIS/php, all have the upload folder on the same settings, all worked fine with WP 3.2.1.

    The only difference worth mentioned in these 3 WP installations is that for some uknown reason the working WP 3.3 is also capable on doing automatic updates. I am manually updating the other two.

    Well. You could always try manually updating the broken site.

    Did anyone try changing the file permissions on the 12 folder, just for a lark?



    Guys, I think I have the solution (or at least a workaround).

    I gave write and modify permissions to the Users user over the wp-content folder (I had done it on the uploads folder – as I usualy do). The prob was magicaly solved (I upgrated one win7 installation already).

    Unfortunately, giving the Users group modify permissions on the entire wp-content folder is not an acceptable workaround unless you’re willing to compromise the security of your blog. The worker process for your web server should not have modify permission on any directory except where absolutely necessary. If you grant this permission, you open yourself up to people potentially being able to alter your content, deface your blog or host malicious files if they find vulnerabilies in WordPress or any plugin you’re using. Granting full permission to the Everyone group (as a test) on the /wp-content/uploads folder should be more than enough for WordPress to upload files to it. Since this test failed, and since I’ve never had any issues prior to upgrading to 3.3, I can only assume something was changed in the uploader code that is now having a negative impact on Windows/IIS based WordPress installations.

    Still looking for a solution, but haven’t found one yet.



    How is it possible for someone outside the users list of my win PC to get access to the folders below the contents folder as long as he doesn’t have access to my PC? Am I missing something? (I am on IIS).

    I agree that the folder under consideration should be (and was, on v.3.2.1 and older) the uploads folder but then the problem is on the WP 3.3 and not our settings. We all had the ability to upload until we moved to v.3.3. Any official WP position on this?

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘[Resolved] File Upload Error After Upgrading to 3.3’ is closed to new replies.