Support » Plugin: Pods - Custom Content Types and Fields » File upload doesn't work in custom setting page

  • Resolved cappec

    (@cappec)


    Hi,

    I just created a custom setting page with 2 custom fields of “File/image/video type.
    When I access to the setting page I see the two “Upload” buttons, but when I click on one and I upload/choose a file the page return to the custom setting page and I still see the upload buttons.
    No trace that the file choosen is linked to the custom field.

    Can someone help me?

    Thanks.

    https://wordpress.org/plugins/pods/

Viewing 1 replies (of 1 total)
  • Plugin Author Jim True

    (@jimtrue)

    Worked absolutely fine for me just now:

    View post on imgur.com

    You might want to check what type of file you’re using. If the MIME type isn’t on the whitelist for uploads (or if you have that setting set incorrectly in the ‘Additional Field Options’, ‘Restrict File Types’ for your Image/File Upload field, it won’t allow the field to be uploaded.

    JPG/PNG share a mime type so there should be no issue there, but if you’ve got it set for JPG/PNG and you’re uploading a PDF or EPS or SVG or something like that, it won’t upload at all. Certain file types are also automatically restricted by WordPress and need to be added to their file attachment ‘whitelist’ filter for WordPress upload_mimes:
    https://codex.wordpress.org/Plugin_API/Filter_Reference/upload_mimes

Viewing 1 replies (of 1 total)
  • The topic ‘File upload doesn't work in custom setting page’ is closed to new replies.