• Resolved irinartdc

    (@irinartdc)


    Hello,

    Files won’t upload via the signup form. I have tried making those fields required and it won’t upload anything even though I have selected the files. It works via the back end but not the sign-up form.

    Any thoughts?

Viewing 15 replies - 1 through 15 (of 38 total)
  • Plugin Author xnau webdesign

    (@xnau)

    Can you supply some more details, what exactly do you see when you attempt to upload? How do you know it didn’t work?

    Thread Starter irinartdc

    (@irinartdc)

    I have made the upload fields required, when trying to submit the form after adding the images it says the fields are required as if I didn’t add any images.
    Please see screenshots: https://imgur.com/Gr4eTX0

    https://imgur.com/vyQ1saf

    Also, please see the web page: https://mmctraining.co.uk/application/

    • This reply was modified 2 years, 4 months ago by irinartdc.
    Plugin Author xnau webdesign

    (@xnau)

    How do you have the image field configured?

    Thread Starter irinartdc

    (@irinartdc)

    Please see image below:

    https://imgur.com/bL4rSAs

    If I make the fields Not required it will submit the form but no images will appear in the back end.

    I have exactly the same problem since yesterday. I’ve checked for any issues with the server, disabled other plugins, reinstalled pdb, changed fields and general settings. Thanks in advance for your help.
    This is the page: https://almurarte.es/registro-de-artistas/

    Plugin Author xnau webdesign

    (@xnau)

    I’m not sure what the problem is, I don’t see it here in my tests. The image field configuration looks good.

    I suggest you turn plugin debugging on, clear the debugging log, then test your form to see if there are any problems with uploading the file.

    I have already done it. I have tried again and it does not throw any error.

    In the browser console I see this error now:
    “Unchecked runtime.lastError: The message port closed before a response was received.”
    But it is the first time and I suspect that it has nothing to do with the problem.
    Thanks again for your help

    • This reply was modified 2 years, 4 months ago by trota.
    Plugin Author xnau webdesign

    (@xnau)

    So…what exactly do you see when you try to upload an image?

    Have you checked to make sure the “File Upload Location” setting in the Participants Database settings is correct?

    From my limited POV, image files will not upload if the filename contains special characters like: #
    D//

    The image is selected correctly. If I mark the field as “required” when submitting the form, I get the message that the field is required. If I mark it as “not required” the form is accepted and added to the database but without any images.
    From the administration panel I can upload images without any problem. This started happening two days ago at most.

    I forgot to say that I restored a previous wordpress backup but it keeps happening.

    • This reply was modified 2 years, 4 months ago by trota.
    Plugin Author xnau webdesign

    (@xnau)

    OK, so you see the problem on the front end only. Could it be page caching? You will need to exempt your signup page and the thanks page (if using it) from page caching.

    @davidk Thanks for the tip on the filename, a “hash” is a little unusual in that context, but should be legal. I’ll check into it.

    LiteSpeed cache is disabled on my server and I don’t have any caching plugin. I have tried clearing the browser cache several times and accessing from different devices and browsers. Would you be so kind as to point me to the correct way to do what you indicate. I have tried to do it from .httaccess, but the problem persists. Thanks again.

    • This reply was modified 2 years, 4 months ago by trota.

    Hi again, Again from my limited POV, picture files that include a # upload to the WP Media Library, but don’t show on a single record or list. Maybe different via a signup, but …
    Thanks.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘File upload’ is closed to new replies.