WordPress.org

Support

Support » Multisite » [Resolved] File type does not meet security guidelines

[Resolved] File type does not meet security guidelines

  • Hi there,

    i activated the multisite feature in my blog and the most things are working correctly. Except the plugins and the file upload.

    In this topic i just want to find a solution for the upload problem. if i try to upload an image i get the following error:

    Warning: Invalid argument supplied for foreach() in …/wp-includes/functions.php on line 2365. Dismiss “image.png” has failed to upload due to an error. File type does not meet security guidelines. Try another.

    I have allowed to uplaod png files and there is enough space. Someone have an idea what could be wrong?

    Thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Check for caps or not.

    Go to Super Admin -> Options, “Allowed file types”.

    paste in here what you put in there.
    Also give a link to your site. Yes, it really does help.

    “Allowed file types”: jpg jpeg png gif pdf

    And the links to my site.
    Main Blog: egoo.de (In this Blog everythings works fine)
    Blog “2”: egoo-journal.com (Problem like described above)

    Notice: To setup WP Multisite with Multiple Domains i used the following way: http://www.interconnectit.com/840/wordpress-3-0-multisite-with-multiple-domains-setup/

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Get to domain mapping plugin, it’s much easier.
    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

    The author of that post was unaware there was a plugin that did all the work for you. (and there’s a couple extra bits)

    It’s possible if you changed the site_id table to 2, you’ve basically made a second *network* not a second site. The tables use old WPMU terms, it’s a little confusing if you’re not used to it. The second network will also have the ability to have child blogs.

    Go to egoo-journal.com/wp-admin/ms-options.php. Double check the allowed files there. My guess is png isn’t on this one.

    @andrea Thanks for your help!

    Unfortunately i got the error “You do not have permission to access this page.” But i am sure that i’m logged as admin.

    But your comment redarding the second network is very interesting. i still have some more problems with the news site/network. So i think it could be better if i revoke all edits and try the plugin you recommend.

    Do you think that’s the better way, too?

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Yes, I do.

    OK, now i deleted the created blog and all tables in the database and added a new one. With the named plugin above everything works fine!

    Thanks!

    I am having a similar problem trying to upload kml and gpx (mapping) files. I am also new to wordpress… how to you “Go to Super Admin -> Options, “Allowed file types””?
    I am logged in as the original “admin” for the site and don’t see any such setting.
    using wp 2.9.2
    Thanks,
    joe

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    You only get the Super Admin menu if you are running a network of sites in 3.0.

    You get a Site Admin menu if you’re running WPMU 2.9.2.

    If you have a single WP install before 3.0, you don’t get this area.

    Hello, I’m also having this problem, using wordpress 3.0 without MU feature activated. I tried to upload a 2 mb 7z file and I keep receiving this message though I have made sure to increase file size limit in php.ini (I’m using vps with kloxo installed)

    Could anyone help me?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] File type does not meet security guidelines’ is closed to new replies.
Skip to toolbar