Support » Fixing WordPress » File Permissions when they’re 777?!

  • I’ve just tried uploading from 1.5 to 2.0 and I now get a file permissions error. No details, just ‘A file permissions error has occurred. Please check the permissions on the script and the directory it is in and try again.’

    So, thinking that I’d use a process of elimination, I made every folder 777, but it still occurs!

    Does anyone know what I’m doing wrongly?

Viewing 13 replies - 1 through 13 (of 13 total)
  • A file is not a folder ;’) If this is a result of using the built-in theme editor (bleh), you’ll need to change the permission on the files you’re trying to edit to at least 664. If that doesn’t work, you can try 666.

    If that doesn’t work, then you haven’t given enough information.

    Well, that is all of the information. I’ve since set every file and every folder to 777 and still nothing works. If I go to the URL of the site – whether or – I get the message: ‘A file permissions error has occurred. Please check the permissions on the script and the directory it is in and try again.’

    You should never have to make a file 777.

    Describe to me how you could re-create the error? What are the actions/steps leading up to the error?

    It’s possible that I’m missing something, but I don’t think there’s anything to add to that in my first post.

    I upgraded the site from 1.5 to 2.0, but when I go to I get the message above.

    The reason I set everything to 777 is that I thought I could then workout which was the offending file by a process of elimination. But it still happened.

    It gets worse… I’ve since (backed-up and then) deleted everything. I then reinstalled 2.0, changed the config settings, ran the upgrade script and I still get the message on index.php. However, I can now get to the admin area, e.g.

    How are you changing/checking file permissions? FTP? CPanel?

    Sorry, FTP (WS_FTP, to be exact).


    Does anyone have any advice?

    Please be patient and don’t bump. It does no good, only harm.


    I’m having the same problems with setting permissions using FTP (WS_FTP). My problems started yesterday as I tried to repair “Subscribe RSS”. I get the following error:

    The XML page cannot be displayed
    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

    End tag was not expected at this location. Error processing resource ‘


    I can recreate the same error above when I attempt to run wp-rss2.php to generate the synication feed. I checked support and there was alot of discussion involving .htaccess and setting file permissions.

    I have tried every concevable combination of file permissions and I’m afraid things are gummed up good. The site works once again but the icons/images for TechnBlue theme no longer display in postings as they did before. I’ve tried to set permissions on wp-content, themes, TenchnoBlue->images, etc.

    In addition, I have not fixed the “Subsribe RSS” found in sidebar.php. It appears the wp-rss2.php needs to have access to some area and the permissions are not set up in default installation.

    How can I restore default file permissions?
    What needs to be in .htaccess? CHMOD 666.
    How do I get wp-rss2.php to generate feed for my blog?



    divrom: I can only suggest you try to get back to basics: Make folders 755 (except, perhaps wp-content/ and/or wp-content/uploads/, those might need to be 777). Make all files 644 and test again. Report back results…


    I changed the file permissions for the folders and when I went back into WP Admin I could see the default image for my TechnBlue theme. Selected it and all the image icons were restored. Should have documented every move…Duh. It works and I’m happy. The last problem with my installation involves synication of my blog feed. The “Subsribe RSS” button fails and I’m pretty sure it has to do with file permissions and wp-rss2.php. What script populates the wp-rss2.php? Do I need to tweak .htaccess. I attempted to add the “invisible” system file to Lycos server by renaming htaccess.txt to .htaccess using WS_FTP but the file remains visible in FTP client. However, in WP Admin it sees the .htaccess file and appearently I can edit it. Something new to learn here I suspect??? Could it be Permalinks?

    Teacherguy 🙂



    Thanks Yosemite.

    For anyone who has exactly the same problem as me, I’m afraid that I never did solve it. In the end I re-installed to a new directory and just re-directed (with mod_rewrite rules) from the old.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘File Permissions when they’re 777?!’ is closed to new replies.