Support » Installing WordPress » File Permissions Ownership Nightmare

  • So I just had to migrate to a new server and everything went fine. I used SCP as the root user to pull everything over.

    However, now there are all kinds of problems related to permissions and ownership of files. Most notably, none of my inside pages will load (everything is 404), however the front page loads fine. I suspect this is related to a missing htaccess file in the root directory…

    I know how to FTP in and try to change permissions, I can also execute SSH commands. But I have NO IDEA who’s supposed to be the owner of everything and what the directory permissions are supposed to be. I have even tried Chmodding the entire site 777 and it still doesn’t solve the problem.

    Can someone give me a simple step by step of how I figure out who owns what, how to set that up correctly and what the permissions should be for every file? I have been through the codex and tried every combination I could find but still no luck.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Permissions for the files should be 644. folders – 755
    As I see you have 404 error. It isn’t permissions problem

    Hmm…. what do you suppose might be causing that? The front page loads just fine, then all the article pages are 404’d

    whooami

    (@whooami)

    Member

    reset your permalinks. its part of the moving wordpress directions.

    reset them? The setting seems to be correct. However, I’ve now graduated to 500 Errors instead of 404.

    I’m fairly certain this all has something do to with the htaccess file and the permissions to write it… what should those be? How the heck do I figure out who the “owner” of wordpress is? vs. the “owner” other things?

    Moderator cubecolour

    (@numeeja)

    ɹoʇɐɹǝpoɯ

    I agree that it sounds like it could be a permalinks issue.

    To see if it is, go into into Setings -> Permalinks

    Change your permalinks to default, save changes, then back to how they were and save changes again.

    This has fixed a similar issue for me after moving to another server.

    woah! that might have worked… thanks

    whooami

    (@whooami)

    Member

    funny how all those years of experience pays off, eh 😛

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘File Permissions Ownership Nightmare’ is closed to new replies.