• Hi, I have a strange behavior with a PDF document, which can be downloaded from my WordPress-site:
    First, I´ve uploaded the PDF into the media library. Second I´ve created a link in my footer-column/widget-area on my Website to make the PDF downloadable. It worked.
    But then, after time, the link and the download did not worked any more. “Forbidden access”. So I found the following solution: with FileZilla I went to the PDF file, right click, file permissions and I set the value to “644”.
    It worked, the PDF was downloadable again – but only for some days. After time the same problem occurs again and I have to set the file permission again and again and again.

    Does someone can give me a hint what the problem could be? Is it maybe because of my Caching-plugin?

    Thanks in advance.

    • This topic was modified 2 years, 1 month ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @hbk123

    Can you tell us what the file permissions are when the change happens?

    Is there perhaps something being applied to files on your server, perhaps by your web host?

    Thread Starter hbk123

    (@hbk123)

    Hi Jonathan, thanks for your reply. I will tell you as soon as the file permission will switch again. Normally, this is after several days, maybe a week or little more (haven´t measured it exactly)…

    regards

    Thread Starter hbk123

    (@hbk123)

    Hi Jonathan, as expected it happened again. This time I´ve checked, that the file permission changed to “200”.
    I don´t know if my web host is applying something to my files. This strange behaviour is only with this PDF. My provider is ONE.com
    Do you have any idea?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘file permissions of a downloadable PDF is changing on its own’ is closed to new replies.