Support » Fixing WordPress » File Permissions – I killed my blog!

  • Resolved pattyb


    I was trying to add a page to my wordpress blog today ( and I got an error message about a parent directory (wp-content) not being writable by the web server. So I went did chmod on the wp-content folder.

    Unfortunately now my blog won’t display at all, and when I go to Manage Themes, none of the themes I have installed display!

    Please tell me what to chmod the wp-content directory back to. Might as well tell me what to chmod the themes directory to as well, in case I got real crazy and changed that.

    Thank you!

    Patty Bradley-Diehl

Viewing 2 replies - 1 through 2 (of 2 total)
  • Try 777 and then look at the other directories in your install and try to reduce it to that level.

    And adding a “page” if we are talking about Write > Write Pages) shouldn’t trigger that parent directory error message.

    Thank you. That solved the problem. And I was actually under Page Management, clicked “Create a New Page” and then tried to upload a PHP file. Dumb, I know. I’ve been trying to figure out how to apply the WP themes to the other (non-WP) pages in my site. I love being able to change themes. I’ll figure it out. Thanks for your help!


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘File Permissions – I killed my blog!’ is closed to new replies.