Support » Fixing WordPress » File Permission

  • Resolved insub2

    (@insub2)


    I’m having problems with file permission.

    While trying to upload an image to a folder on my home server and I’m getting the following error:

    Unable to create directory /home/insub2/Websites/Good Morning rEvolution/wp-content/uploads. Is its parent directory writable by the server?

    Trying to get the AmR iCal Event List plugin to work, I get this error:

    Error creating cache directory (/home/insub2/Websites/Good Morning rEvolution/wp-content/uploads/ical-events-cache/)

    HOWEVER!!!
    The root directory and every sub-directory/file is set to 777. And both the wp-config.php and .htaccess files were created with no issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • try creating the folder ‘uploads’ in your wp-content folder. and set the perms to 777

    Already did that. Did the whole uploads/2009/06/ thang too. No joy.

    Even tried switching the owner and group to www-data (which is the owner and group of the WP created .htaccess file). No joy.

    I had switch the spaces to underscores in the directory holding WP and thought I had made all the appropriate changes to WP. But, alas, there was one more thing. Settings -> Miscellaneous -> Store Uploads in this folder. So it was trying to create a new directory in my web root–which is not writable by anyone but me.

    All is well now. Thank you for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘File Permission’ is closed to new replies.