Support » Plugin: W3 Total Cache » file path to htaccess file

  • cvc1968


    I’m working on migrating a site to a new host and I’m having all kinds of problems with W3 Total Cache. It worked fine on the old host structure, but having a big issue on the new host. I’ve tried uninstalling and re-installing the latest version of W3TC (9.2.11), then uninstalling and re-installing the version I had previously had running on the the old host site which worked (9.2.9). Each version gives a different error message. The message provided in the 9.2.9 installation seems to point to the problem.

    W3 Total Cache Error: The plugin tried to edit, /.htaccess, but failed. Files and directories cannot be modified. Please review your file permissions. A common cause is .htaccess and /home/wvuped5/public_html/wp-content having different ownership or permissions.

    When clicking the “Show Technical Information Button” it shows:

    • File: /home/username/public_html/wp-config.php File permissions are 644 File owner: wvuped5:wvuped5
    • File: /.htaccess File permissions are 0, however they should be 644. File owner: root:root
    • Directory: /home/username/public_html/wp-content File owner: username:username
      Owner of current file: username:username
    • The files and directories have different ownership, they should have the same ownership.

    The thing that jumps out at me is that the first error shows the complete server filepath that lives BEFORE the WordPress files, but the second seems to be looking for htaccess at the root directory of the server, rather than the root directory of the site.

    Note that the .htaccess file at /home/username/public_html/.htaccess is correctly set to 644. Also note that I manually added the w3tc code to that htaccess file, but w3tc doesn’t recognize that the code has been added.

    I cannot test this theory by creating an .htaccess file at the root… the highest level at which I be able to create a file is /home/username/.htaccess

    Does anyone know if this is a problem relating to the plugin or to my server configuration?

    Note that WordPress had no problem finding the htaccess file and inserting the Permalink code when I set the Pretty Permalinks.

    Most importantly, does anyone know how to fix this problem?


Viewing 3 replies - 1 through 3 (of 3 total)
  • I am having the same problem migrating a site to a new host.

    Perhaps there is something in the base WordPress configuration pointing to the wrong base for the .htaccess?



    Forum Moderator

    As per the Forum Welcome, please post your own topic.

    htaccess file should have 777 permissions during installation of W3T. wp-content should also have them. (temporary)

    You must log in to your hosting and change the permissions. If you can not find a file htaccess, you can create on your computer with “bloc notes” (tex edit) and save it as “htaccess” without the starting point. When you upload to the server with your ftp program, rename it and assign a point ahead.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘file path to htaccess file’ is closed to new replies.