WordPress.org

Support

Support » How-To and Troubleshooting » File not found (wp-comments-post.php)

File not found (wp-comments-post.php)

  • When I post a comment I get the following error:

    Firefox can’t find the file at http://www.DOMAIN.TLD/wp-comments-post.php.

    But the comment still shows up on the site…

    I’m using WordPress 3.0 with the default theme (Twenty Ten) – and I’ve:

    • deactivated all plugins
    • tried repairing the database
    • tried reinstalling WordPress completely (from a fresh download)

    – but no luck…

    As far as I can tell the error is triggered when I assign a new author to a post. If I switch the post back to its original author the error no longer appears.

    Any help would be much appreciated!

    /Janus

Viewing 8 replies - 1 through 8 (of 8 total)
  • re-upload the fresh WP3.0. Keep a backup first.

    Thanks for your reply, Chinmoy

    I just tried re-uploading the fresh WP3.0 – unfortunately it didn’t solve the problem…

    tutorialsbucket

    @tutorialsbucket

    hello,

    I am having the same problem, even I have installed WP3.1 .. Please give us some sort of solution.

    http://www.tutorialsbucket.com/wp-comments-post.php

    Thank you all.

    masumsoft

    @masumsoft

    Hi,
    I’m facing a similar problem in my site idolbin.com. When I post a comment it returns 404 error. I’m using custom permalink structure category/post_title and everything else is just working fine. Only the comment posting is not working 🙁

    reset the permalink settings and then check once.

    masumsoft

    @masumsoft

    I’ve reset the settings several times, done almost all the tricks available on net, but no luck 🙁

    tutorialsbucket

    @tutorialsbucket

    yeah i am still having the same problem … WP coders must aware with this bug.

    Mvd

    @micx51

    ssame problem.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘File not found (wp-comments-post.php)’ is closed to new replies.