WordPress.org

Forums

W3 Total Cache
"File name too long" Apache Error with Minify Rewrite (3 posts)

  1. doublesharp
    Member
    Posted 2 years ago #

    When I have the url rewrite enabled for Minify on CentOS 5.9/Apache 2.2.3/PHP 5.4/Wordpress 3.5.1/W3TC 0.9.2.7 I get a "403 Forbidden" error in the browser when trying to request the minified files, and looking at the error_log, I see:

    [Thu Feb 07 16:59:03 2013] [error] [client x.x.x.x] (36)File name too long: access to /wp-content/cache/minify/000001/jZHhVsMgDIVfqIA784VoyLpsQGoI7synF7uuztl6_EVyv3BDwt6d3irKtdu7SnNsK1lgQZsody_uVBwcuWC2M17kW24ONUO3c2iAU0IBNMlThCPC2S2RWertok1OT40vFAbUNZK4FlwDgoU-fB9XYRA_DFuwr6qc18jIhZTWWSAfeZjIzhWGlrbRc0ZQl7DRaWU3YWsvreLC_MvZK44EZ5TJ_dX50E7Te5m7tTt3M-dLQS1fTgfhrJhDKw9G2YAX_fPC_HFjrAPl8j_vB3wfndIYMXFo87eFUP62tg9sq1L43ZP8bGxG4VBBjWBWH6cXPEmf.js failed

    Disabling the url rewrite gets it working again, but the rewritten URLs would be more desirable. Please let me know if there is other info that would be helpful.

    Thanks!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you, working on fixing this for the next release.

  3. hostingindonesia
    Member
    Posted 2 years ago #

    I get same error message and your plugins now solved this problem automatically. I use the latest version of your plugins W3TC 0.9.2.10/Wordpress 3.5.1. I dont know Why your plugins create too long file name for minified file(in my site 180+ charater file name for the css file name)? Is there option to short it?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.