Support » Plugin: WP Document Revisions » File name changes on upload & 404 error

  • Hi Ben,
    This is a great plugin and I’m really looking forward to using it.

    I have set it up on a localhost (test server) and it is working great and uploading the documents to the selected folder. It is however changing the file names to something longer and bizzar (e.g 6c135699783a2de4c23d6d356f6308e9.pdf) after which when I browse to the front end and try to access the document it gives me a 404 error.

    I have even tried browsing directly to the long file name and still get a 404 error.

    1. Is there a setting that I am missing?

    I appreciate your support Ben

Viewing 2 replies - 1 through 2 (of 2 total)
  • I too am getting 404 errors on documents even after repeatedly updating permalinks, clearing cache and setting status to public/final on PDF documents.

    It does not appear to make a difference whether I am logged in or not.

    404 error not found on all uploaded documents.

    (See for example:

    Having some difficulty recreating this. I’ve done the following, in order:

    1. Uploaded a document.
    2. Published the document
    3. Create a new post
    4. Added [documents] to the post
    5. Published the post
    6. Checked out the post on the front end
    7. Clicked a document listed in the post body
    8. The document then downloaded

    Is there something you’re doing differently?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘File name changes on upload & 404 error’ is closed to new replies.