Support » Plugin: Simple Fields » File field not working…

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Pär Thernström


    Sorry to hear you’re having problems. I actually found a bug with the file field and released 1.2.1 this morning. Can you try that version and see if it helps?

    I think 1.2.1 is what broke my install. It was working fine last week…this morning I updated to 1.2.1 and the File field stopped working.

    Any ideas on what I can do?

    I made some testes here , and i presume that the bug occours when u create a new post and u try to upload to a custom-field a file for example, and u cant, cuz there is an javascript error occouring…

    I made a test, i saved a new post withouth using the custom-fields, and then tried again to attach files, and at this time i could attach…

    so to help u, i think the bug happends when u try to attach a custom-field without saving it first…

    I forgot to say, that i love this plugin, and im so pleased to have it!
    Thank indeed Pär Thernström!
    And if u need help to fix it u can contact me:

    The problem is happening on an existing post.

    When I load the page, I’m getting “init simple_fields_file_field” which I’m guessing is a legit log message. But then when I click “Select file” I get the following JavaScript error:

    Uncaught ReferenceError: _wpMediaViewsL10n is not defined

    Hope that helps with the debugging.

    Hi Nate, i only have the problem to use the Custom Fields, when i create a new post. At an existing post, it works fine for me.

    But i have the same problem here in a new problem “init simple_fields_file_field” …

    Plugin Author Pär Thernström


    Sorry for the bug, but thanks a lot for debugging it a bit.. I can not reproduce it myself, so really need your helpt. _wpMediaViewsL10n is available for me whenever I am in the post edit screen…

    Can you give me some more details, like are you using regular posts or custom post type with a very limited output (for example no editor) + what other plugins do you have?

    Can you do this in the console btw, and what does it say:
    console.log( _wpMediaViewsL10n );

    (for me it’s object with different transations…)

    Plugin Author Pär Thernström


    oh, and if any of you are brave enough can you send some login information to a site where i can see the error in action? if so, send to


    I think you hit the nail on the head—the page I’m using these fields on is a Custom Post Type with no editor. It’s only a title and the fields supplied by the plugin.

    I’m guessing if you remove the editor from the Custom Post Type, you’ll start seeing the same error.


    Plugin Author Pär Thernström


    Hooray, we hopefully found the problem then!

    I did get the same error when using the file field on a custom post type with no editor.

    The problem is hopefully gone with version 1.2.2 that I just uploaded. Please try that one and let me know if it works.

    Thanks for the help everyone.

    Hey Pär!

    The bug its still occouring for me.
    But now i found exactly how it happends.

    When i use a custom field with the ‘use_html_editor’ flag on.
    I cant use file fields and posts relation fields, neither other javascript button on the page… cuz the editor is crashing everything.

    When i use an textarea field withouth the flag to use the html editor, the bug dont occour!

    Can u review that flag code?

    Ty bro , ur awsome!!

    Plugin Author Pär Thernström


    miguelmedeiros: do you still get a message about _wpMediaViewsL10n not being defined? can you give a screenshot of what your console looks like when the error occurs?

    did you have any other plugins installed btw?


    1.2.2 fixed my specific problem. I haven’t thoroughly tested it, but the one file I was trying to attach now works.

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘File field not working…’ is closed to new replies.