Support » Plugin: ShortPixel Image Optimizer » File failed to open No such file or directory

  • Hi guys,

    I updted from 4.14.1 to 4.14.5 and it is breaking my staging site. I’m getting the following error:

    Warning: file_get_contents(/nas/content/staging/bostonhernia1/wp-content/plugins/shortpixel-image-optimiser/build/shortpixel/composer.json): failed to open stream: No such file or directory in /nas/content/staging/site/wp-content/plugins/shortpixel-image-optimiser/build/shortpixel/PackageLoader.php on line 10

    Fatal error: Uncaught Error: Class ‘ShortPixel\ShortPixelLogger\ShortPixelLogger’ not found in /nas/content/staging/site/wp-content/plugins/shortpixel-image-optimiser/wp-shortpixel.php:224 Stack trace: #0 /nas/content/staging/site/wp-settings.php(342): include_once() #1 /nas/content/staging/site/wp-config.php(133): require_once(‘/nas/content/st…’) #2 /nas/content/staging/site/wp-load.php(37): require_once(‘/nas/content/st…’) #3 /nas/content/staging/site/wp-admin/admin.php(34): require_once(‘/nas/content/st…’) #4 /nas/content/staging/site/wp-admin/index.php(10): require_once(‘/nas/content/st…’) #5 {main} thrown in /nas/content/staging/site/wp-content/plugins/shortpixel-image-optimiser/wp-shortpixel.php on line 224

    Can someone please direct to a solution?

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hey @oscarssanchez – thanks for your message, the error you’re facing it is very unusual…

    Could you please try to deactivate & remove ShortPixel plugin and then install it again and see if this solves the problem?

    I would appreciate your follow-up on this,
    Alex

    Hi @shortpixel ,

    Sorry for the delay, i must add this is hosted on wp-engine. My guess is that there is some restrictions with the hosting provider, as it looks like the issue lies with the new way the autoload is handled. May I ask this is adapted so it is compatible with more hosting providers? This site is hosted on WPEngine.

    Thanks!

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hey Oscar,

    Our plugin should work well with all hosting providers. We have several clients with WPEngine and it’s the first time we hear about something like this.

    Could you please try to deactivate & remove ShortPixel plugin and then install it again and see if this solves the problem?

    If not, I would suggest contacting WPEngine so they can assist you in this.

    Cheers,

    Thanks for the response @sixaxis

    I have tried removing the plugin and then installing it again, sadly the issue still remains the same. As noted, all works well in 4.14.1, which is what we have installed for the moment.

    Similar errors seem to happen with WP Engine per https://wordpress.org/support/topic/php-7-2-fatal-error-4/ . I have also tried installing the dev version in this thread, unfortunately with the same results.

    Is there any chance to get a second review for a fix for this in the plugin code? We can help out with any testing required or the like.

    Thanks again for your time

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hello Oscar,

    Sure, we will take a look. In order to further investigate this, we would need admin access to your WordPress installation. Can you please send us the credentials using the contact form here? Make sure to copy/paste the URL of this conversation too.

    Thank you!

    Hi @sixaxis ,

    Sorry for the delay here,
    Due to the client restrictions we cannot provide this access. Is there something else we can do to help you with this?

    Kind regards,

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hi Oscar,

    There is a new version of ShortPixel Image Optimizer (4.14.6). Can you please try with that one?

    Best,

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.