Support » Plugin: BackWPup - WordPress Backup Plugin » File backups failing

  • Resolved betyonfire

    (@betyonfire)


    Backups have been running along fine until a month or so ago, when I started to get errors on the file backup. The database backup continues to run just fine. I tried tweaking the settings (max script execution to 25, switching from zip to gzip or tar, adjusting memory limit to 256m in config), but I still can’t get them running again. Any help would be appreciated. Here’s the error log:

    [INFO] BackWPup 3.4.4; A project of Inpsyde GmbH
    [INFO] WordPress 4.9.1 on http://nehlibrary.org/
    [INFO] Log Level: Normal
    [INFO] BackWPup job: Full Site BU
    [INFO] Logfile is: backwpup_log_f6a21a_2018-01-08_08-48-50.html
    [INFO] Backup file is: backwpup_DL3KEGSQ02_2018-01-08_08-48-50.zip
    [08-Jan-2018 08:48:50] 1. Trying to make a list of folders to back up …
    [08-Jan-2018 08:48:51] Added “wp-config.php” to backup file list
    [08-Jan-2018 08:48:51] 420 folders to backup.
    [08-Jan-2018 08:48:51] 1. Trying to generate a manifest file …
    [08-Jan-2018 08:48:51] Added manifest.json file with 5.07 KB to backup file list.
    [08-Jan-2018 08:48:51] 1. Trying to create backup archive …
    [08-Jan-2018 08:48:51] Compressing files as ZipArchive. Please be patient, this may take a moment.
    [08-Jan-2018 08:54:58] WARNING: Job restarts due to inactivity for more than 5 minutes.
    [08-Jan-2018 08:54:58] 2. Trying to create backup archive …
    [08-Jan-2018 09:22:30] WARNING: Job restarts due to inactivity for more than 5 minutes.
    [08-Jan-2018 09:22:30] 3. Trying to create backup archive …
    [08-Jan-2018 09:30:48] WARNING: Job restarts due to inactivity for more than 5 minutes.
    [08-Jan-2018 09:30:48] ERROR: Step aborted: too many attempts!
    [08-Jan-2018 09:30:48] One old log deleted
    [08-Jan-2018 09:30:48] ERROR: Job has ended with errors in 2518 seconds. You must resolve the errors for correct execution.

    And the debug info:
    WordPress version: 4.9.1
    BackWPup version: 3.4.4
    PHP version: 5.6.32 (64bit)
    MySQL version: 5.5.56-cll-lve
    cURL version: 7.54.0
    cURL SSL version: OpenSSL/1.0.2k
    WP-Cron url: http://nehlibrary.org/wp-cron.php
    Server self connect: Response Test O.K.
    Document root: /home/nehl/public_html
    Temp folder: /home/nehl/public_html/wp-content/uploads/backwpup-f6a21a-temp/
    Log folder: /home/nehl/public_html/wp-content/uploads/backwpup-f6a21a-logs/
    Server: Apache
    Operating System: Linux
    PHP SAPI: litespeed
    Current PHP user: nehl
    Maximum execution time: 0 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: Off
    CHMOD Dir: 0755
    Server Time: 15:39
    Blog Time: 10:39
    Blog Timezone: America/New_York
    Blog Time offset: -5 hours
    Blog language: en-US
    MySQL Client encoding: utf8
    PHP Memory limit: 256M
    WP memory limit: 256M
    WP maximum memory limit: 256M
    Memory in use: 46.25 MB
    Disabled PHP Functions:: show_source, system, shell_exec, passthru, exec, popen, proc_open
    Loaded PHP Extensions:: Core, PDO, Phar, Reflection, SPL, SimpleXML, bcmath, bz2, calendar, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, gettext, gmp, hash, iconv, imap, json, libxml, litespeed, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, readline, session, shmop, sockets, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi @betyonfire
    I think you have a permission problem, please try the following:
    https://backwpup.com/docs/backwpup-error-cannot-create-folder/
    Hope that helps 🙂

    Thread Starter betyonfire

    (@betyonfire)

    The permissions on the directory for file backups are the same as on the directory for database backups and they are running fine. Still, I adjusted it to 777 and tried to run a backup, but it’s still not working.

    Plugin Support duongcuong96

    (@duongcuong96)

    @betyonfire
    I see in your server information that Maximum execution time: 0 seconds , that too low, could you please contact your hosting provider and said to them that PHP max_execution_time has been set to 0 seconds ?
    And please give me a screenshot of your BackWPUp settings too.

    Plugin Support duongcuong96

    (@duongcuong96)

    @betyonfire

    since we haven’t heard back from you, I’m going to mark it as resolved.
    If you’re still having problems, feel free to let us know ;),

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support 😀
    https://wordpress.org/support/plugin/backwpup/reviews/

    Thread Starter betyonfire

    (@betyonfire)

    Sorry for not responding earlier — I was sort of hoping the issue would go away on its own. No such luck.

    I adjusted the max_execution_time by adding this to my .htaccess file:
    php_value max_execution_time 300

    And that is now appearing in the settings, but the backups are still failing. Here are the settings:

    WordPress version	4.9.2
    BackWPup version	3.4.4 Get pro.
    PHP version	5.6.33 (64bit)
    MySQL version	5.5.56-cll-lve
    cURL version	7.54.0
    cURL SSL version	OpenSSL/1.0.2k
    WP-Cron url	http://nehlibrary.org/wp-cron.php
    Server self connect	Response Test O.K.
    Document root	/home/nehl/public_html
    Temp folder	/home/nehl/public_html/wp-content/uploads/backwpup-f6a21a-temp/
    Log folder	/home/nehl/public_html/wp-content/uploads/backwpup-f6a21a-logs/
    Server	Apache
    Operating System	Linux
    PHP SAPI	litespeed
    Current PHP user	nehl
    Maximum execution time	300 seconds
    Alternative WP Cron	Off
    Disabled WP Cron	Off
    CHMOD Dir	0755
    Server Time	17:50
    Blog Time	12:50
    Blog Timezone	America/New_York
    Blog Time offset	-5 hours
    Blog language	en-US
    MySQL Client encoding	utf8
    PHP Memory limit	256M
    WP memory limit	256M
    WP maximum memory limit	256M
    Memory in use	44.50 MB
    Disabled PHP Functions:	show_source, system, shell_exec, passthru, exec, popen, proc_open
    Loaded PHP Extensions:	Core, PDO, Phar, Reflection, SPL, SimpleXML, bcmath, bz2, calendar, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, gettext, gmp, hash, iconv, imap, json, libxml, litespeed, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, readline, session, shmop, sockets, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib
    Plugin Support duongcuong96

    (@duongcuong96)

    @betyonfire
    Sorry for my late reply, could you please give screenshots of your job setting?
    Also, could you shows me the folder permission of backwpup-f6a21a-temp folder?
    Thanks!

    Thread Starter betyonfire

    (@betyonfire)

    I managed to figure this out by increasing resources on tbe account and switching to tar gzip backups.

    Plugin Support duongcuong96

    (@duongcuong96)

    @betyonfire
    Great to hear that it’s working for you 🙂
    Could you please share to us your configuration? That may help others people too 🙂
    Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘File backups failing’ is closed to new replies.