Support » Plugin: File Away » File Away: Subdirectories Links don’t work

  • Hey Guys,

    I’m working on the intranet page of my company with the Woffice Theme by Alkaweb.

    We linked our internal documents via a symlink to the WordPress folder and all the directories and files are showing up nicely.

    Though, when I click on a directory link of a list item, it just refreshes the page. Doesn’t open the subdirectory so I can browse the other files of that subdirectory.

    Here’s a screenshot of the view: https://i.imgur.com/yCkPauI.png

    I used the shortcode:
    [fileaway type=”table” name=”MYDIRECTORYNAME” pagesize=”25″ paginate=”true” directories=”on”  exclude=”EXCLUDES HERE” mod=”no” flightbox=”multi”excludedirs=”EXCLUDE DIRS HERE” ]

    What do you think?

    Cheers,
    Fred

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author thomstark

    (@thomstark)

    Do you have Allow Symlinks enabled on File Away settings?

    What type of server are you using? (Windows, Linux?)

    Is your Site URL the same as your WordPress URL in WP General Settings, or is it different? If different, what is your Root Directory setting on File Away Settings?

    What are some examples of subdirectory names that aren’t working?

    The reason the subdirectories are not working is because they are not resolving as real paths for some reason. We need to isolate the cause of that.

    Dear Thomstark,

    Thanks for the quick answer and for you helping to investigate the issue.

    1. “Allow Symlinks” is enabled in the Plugin Settings
    2. The Server is running on Ubuntu (can’t exactly tell which version)
    3. The Site URL in the General Settings is the same as the actual URL
    4. I’m going to send you a mail to thom@thomstark.net with some paths as I don’t know if I can put them public here

    Cheers

    Plugin Author thomstark

    (@thomstark)

    Please send to fileaway.plugin@gmail.com

    I am having the same issue. When I click on a sub-directory, it just refreshes the page and stays in the same directory. Here is my shortcode:

    [fileup sub=”contracts” matchdrawer=”1″ fadein=”opacity” fadetime=”1000″ uploader=”name”]

    [fileaway type=”table” sub=”contracts” searchable=”searchme” customdata=”uploader” fadein=”opacity” fadetime=”1000″ manager=”on” drawerid=”1″ directories=”on”]

    Plugin Author thomstark

    (@thomstark)

    What type of server? What are your base settings?

    [Edit: I was confusing this OP with another one, so I removed some inaccurate info from this comment.]

    • This reply was modified 4 months, 1 week ago by  thomstark.
    Plugin Author thomstark

    (@thomstark)

    You can send info to the above email if you prefer.

    Plugin Author thomstark

    (@thomstark)

    Are you on an intranet or is it a public-facing website?

    julecasa

    (@julecasa)

    It must be said that I am a beginner. So I don’t know the answers to any of your questions. But I will email you in case I give away data that should not be posted here.

    Plugin Author thomstark

    (@thomstark)

    Here was the fix for @julecasa :

    He was using fa-userid in the Base setting and there was a bug when File Away verifies the user-id.

    To fix, open up wp-content/plugins/file-away/lib/inc/inc.open-drawer.php

    Change line 30 from :

    
    if($fa_userid_used && strpos($dir, $fa_userid) === false) $dir = $start;
    

    to:

    
    if($fa_userid_used && strpos($dir, (string)$fa_userid) === false) $dir = $start;
    
    Plugin Author thomstark

    (@thomstark)

    This fix will be included in the next update.

    @fschoenfeldt , can you let me know if this was your issue as well?

    fschoenfeldt

    (@fschoenfeldt)

    Thank you @thomstark and @julecasa for participating solving this issue.

    @thomstark: the class.fileaway_utility.php fix you sent me via E-Mail didn’t work. The fix inc.open-drawer.php:30 fix doesn’t work either.

    I still have to comment out inc.open-drawer.php:24 to get directories working.

    Any update on this @thomstark ?I sent you a mail on June 6th. The fix you suggested is only a temporary solution which will be deleted once the plugin is updated.

    Maybe you just set a switch in the plugin settings that triggers that line of code on/off.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.