Support » Plugin: Caldera Forms - More Than Contact Forms » File attachment works in one install, not the other

  • Resolved adamrice

    (@adamrice)


    I’m using a combination of Caldera Forms, Caldera Custom Fields, and Pods.io to set up front-end posting to a custom content type. One of the things I want users to be able to post is an image.

    I set up a local install using MAMP to mock this up, and got everything working the way I wanted. I replicated my setup on the production server, and almost everything works except for image attachments. The image is being uploaded to the Media Library correctly, and it is being sent in the notification e-mail correctly, but it is not being attached to the post, so it is not available when generating pages. There’s no mismatch in slugs, which might explain it if that were the case.

    Incidentally, I noticed that on the production server, using the older file uploader, a dummy image was being created alongside each real image upload. Switching to the new uploader fixed this. I did not observe this on my local install. I also noticed that on the production server, the file attachment is not available in the “save post type” processor to be set as the feature image; it is available on my local install.

    • This topic was modified 2 years, 8 months ago by  adamrice. Reason: additional info
Viewing 1 replies (of 1 total)
  • Plugin Author Josh Pollock

    (@shelob9)

    @adamrice

    Thanks for using Caldera Forms. By default, the attachment upload will not change the Pods relationship field. This will require custom code. If you need help with this, please open a support ticket at https://calderaforms.com/support and someone from our team will reply within 1 business day.

Viewing 1 replies (of 1 total)
  • The topic ‘File attachment works in one install, not the other’ is closed to new replies.