Support » Plugin: Contact Form & SMTP Plugin for WordPress by PirateForms » Fields not cleared after sending

  • Resolved Malae

    (@malae)


    I have an issue with the Pirate form, in the Hestia theme. It sends the e-mail with no problem. However, after sending, the fields are not cleared giving the impression that it wasn’t sent. It can be resent multiple times. How do I fix this?

    • This topic was modified 3 years, 3 months ago by Malae.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Hey there,

    It should show an alert message saying that your message has been send. Is it not showing? Let me know. 🙂

    Yes, it says has been sent and the page refreshes but the fields are not cleared and the message remains and can be resent multiple times.

    It happens in different browsers: Chrome, FF & IE11.

    Refreshing the page does not clear the fields or the Thanks! message.

    If you don’t have any specific answer with a fix, can you at least tell me what to look for?

    Hello, please send us a ticket by emailing friends[at]themeisle.com and link this thread

    Thank you for replying at last. Fyi, I already asked about this problem in an email exchanged dated 7 July, which you may already have read, because you answered another question that I asked in that e-mail.

    I don’t have a ticket. I will send an e-mail as advised. I presume that ThemeIsle will then open a ticket? I hope I am not wasting more of my time.

    I received an e-mail reply to my e-mail without reference to any ticket! It requested that I install a plugin that would give ThemeIsle complete access to the website and that is unacceptable.

    I made a last effort to solve the issue of the form field not being cleared and was successful, but this caused other problems, which are too complicated to discuss here, so I will mark the status closed.

    Hi there,

    We’ve replied you again. We asked you to do that since it’s not easy for us to understand what’s happening without having admin access. We did read the complete conversation before asking you to do it. I hope we will be able to serve you better in future and we’re really sorry for the inconvenience caused. Can you explain the other problems you’re facing? We want to make sure our product works out for you 🙂

    In ver. 2.0.5, message fields now are cleared and the “Thanks your email was sent successfully!” message appears.

    Refreshing the page does not remove the “Thanks your email was sent successfully!” message.

    Manual attempts with the cursor to delete the “Thanks your email was sent successfully!” message, results in the message fields being refilled with the original message, which can be sent again ad infinitum!

    Hello,

    The message is still present but the message is no longer sent, it’s sent only the first time.

    Let me know if you need anything else.

    After sending the message, the fields are CLEARED, i.e. the message is NOT PRESENT in the contact form after sending.

    If you return to the contact form to send another message, the notification “Thanks your email was sent successfully!” is STILL SHOWING at the top of the form. Refreshing the page does not remove it.

    If you start writing another message, the notification remains on the form. If you ignore it and send the new message, there is no way of knowing if the notification was refreshed, so you do not really know what happened.

    If you try to delete the “Thanks your email was sent successfully!” notification, the old complete (e-mail) message REAPPEARS on the contact form and can be resent.

    There are other issues, but the above should not happen. The design is still broken!

    Updated to version 2.1.0, but all issues still occur.

    Updated to version 2.2.0 and the UPLOAD FILE button has stopped working.

    Also still the same problems reported above and in e-mails including:

    Website e-mail address showing as sender’s address in the header.

    If you try to delete the “Thanks your email was sent successfully!” notification, the old complete (e-mail) message REAPPEARS on the contact form and can be resent. and you get another confirmation.

    Even if the page is refreshed the old message is not cleared. To remove the old message you have to manually delete each field!

    I would use a different contact form except that HESTIA is designed so that it is difficult to use any contact form on the home page, except the Pirate Forms Free & Simple Contact Form.

    The many unsolved issues with Pirate Forms Free & Simple Contact Form will cause me to avoid using ThemeIsle products in the future.

    Malae

    (@malae)

    Updated to version 2.2.1 and the UPLOAD FILE button is still not working, together with other above listed issues, except that the “Thanks your email was sent successfully!” notification can now be deleted.

    Hi There,

    Seems like we have the same conversation at: https://wordpress.org/support/topic/wrong-senders-address-in-header-upload-file-not-working/. I’ll be helping you with the issue there.

    Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fields not cleared after sending’ is closed to new replies.