WordPress.org

Forums

Another WordPress Classifieds Plugin
[resolved] Fields disapear when not in admin (12 posts)

  1. IOWGeek
    Member
    Posted 2 years ago #

    Hi, I have installed the plugin and it is working great, however all of the ad form fields show on the 'place ad' page when logged in as wp-admin however they do not show when logged out, any idea what could be causing this?

    http://wordpress.org/extend/plugins/another-wordpress-classifieds-plugin/

  2. IOWGeek
    Member
    Posted 2 years ago #

    Hi

    I have spent the last 15 hours since my last post on here and on your forum trying to get this to work.

    I have uninstalled and reinstalled the plugin, disabled all other plugins, changed to default 2011 and 2012 theme and tried down grading to different versions of wordpress etc etc.

    The problem is this.

    When I select the category the payment options associated with that category appear but there are no other form fields, none of the standard fields and none of the additional fields see http://www.time-for-yoga.co.uk/prob/1.jpg

    I have tried removing the extra fields plugin and still the same.

    I have paid $160 for all the add ons for this plugin because it looked as if it would do the required job and I need to get it working asap.

    Please respond.

    Thank you.

  3. IOWGeek
    Member
    Posted 2 years ago #

    Hi

    OK, so now I have finally worked out that the plugin requires payment before placing the ad, this seems totally illogical and totally back to front to the norm, but anyhow I have gone through the process and paid and I now get this error:

    [quote]PayPal returned the following status from your payment: INVALID. 43 payment variables were posted.

    If this status is not COMPLETED or VERIFIED, then you may need to wait a bit before your payment is approved, or contact PayPal directly as to the reason the payment is having a problem[/quote]

    Again I have tried disabling all plugins, downgrading version of wordpress, changing theme etc etc still the same problem.

    Please advise urgently.

  4. awpcp
    Member
    Plugin Author

    Posted 2 years ago #

    Hi IOWGeek,

    We have a beta version of AWPCP that allows for payment before OR after the ad details. As you noted, that's not necessarily what everyone likes (and we've been actively working on that for several months, as it touches a great deal of the plugin to modify the workflow like that).

    Part of your frustration here from the second post is that the workflow consists of these steps:

    - Select category
    - Select payment type/plan (if paid)
    - Make payment (in 2.2.1 and earlier, if paid)
    - Enter ad details
    - Upload images (if images allowed)
    - Ad is submitted

    So the PayPal issue you are having, I need to know step by step, what you did. Payment plan selected, images uploaded, any extra fields you have on the category, etc. You debug settings under Classifieds->Debug would help as well, since they will tell us if there's a problem with your server-side PHP or cURL versions.

    Can you tell me those details?

  5. IOWGeek
    Member
    Posted 2 years ago #

    Hi

    The workflow is exactly as described above up to item 3, then once payment is made the error message is shown and you can go no further.

    Where can I download a copy of the beta version that allows for payment after filling in the add details.

    debug file is here http://www.time-for-yoga.co.uk/prob/debug.zip

  6. awpcp
    Member
    Plugin Author

    Posted 2 years ago #

    I haven't made the beta publicly available yet, as the changes to the core plugin required us to update every premium module which isn't complete at this time.

    I've also responded to your email privately. Let me know what you wish to do.

  7. IOWGeek
    Member
    Posted 2 years ago #

    Hi

    Just wanted to say thank you for the private messages you sent and for working within wp-admin to get the issue sorted out, the plugin is working exactly as expected now and I've given it a 5 star rating.

    Thanks again.

    Jamie

  8. awpcp
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks Jamie. Much appreciated.

  9. salvador_villegas
    Member
    Posted 2 years ago #

    i'm having the same issue, i can't seem to go further than step 3.

    i'm getting this error

    PayPal returned the following status from your payment: ERROR. 37 payment variables were posted.

    If this status is not COMPLETED or VERIFIED, then you may need to wait a bit before your payment is approved, or contact PayPal directly as to the reason the payment is having a problem.

    i've already tried the encodind on UTF-8 i saw on another post and is not working

  10. awpcp
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Salvador,

    So your issue is slightly different, but we have a solution for it here: http://www.awpcp.com/forum/viewtopic.php?f=3&t=4205

    It has to do with browser vs. PayPal encoding. This will help fix it.

  11. salvador_villegas
    Member
    Posted 2 years ago #

    I had already done that and it didn't resolved the issue, luckily this issue was only happening in my local evironment, it didn't happened on my developing or production environments. thanks for your help, keep up the good work.

    ps: do yo have an estimated release date for the new version you were talking about? i would like to give it a try.

  12. awpcp
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Salvador,

    The 3.0 release will be soon, although we're still finishing bug fixes on it, so I don't have a firm date yet.

    You are welcome to try the (stable) beta, just contact me here: http://awpcp.com/contact/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Another WordPress Classifieds Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.