Support » Installing WordPress » Field ‘pinged’ doesn’t have a default value

  • Fussspils


    I’m trying wordpress in a testing environment and hosting myself (running IIS6, mysql5, phpmyadmin etc)
    The blogroll feature of wordpress seems to work with no problems but the posting of new blogs doesnt. I get the following errors…

    WordPress database error: [Field ‘pinged’ doesn’t have a default value]
    INSERT INTO wp_posts (ID, post_author, post_date, post_date_gmt, post_content, post_title, post_excerpt, post_status, comment_status, ping_status, post_password, post_name, to_ping, post_modified, post_modified_gmt, post_parent, menu_order) VALUES (‘1’, ‘1’, ‘2005-11-12 13:02:26’, ‘2005-11-12 13:02:26’, ‘test’, ‘test’, ”, ‘publish’, ‘open’, ‘open’, ”, ‘test’, ”, ‘2005-11-12 13:02:26’, ‘2005-11-12 13:02:26’, ‘0’, ‘0’)

    Warning: Cannot modify header information – headers already sent by (output started at \wordpress\wp-includes\wp-db.php:98) in \wordpress\wp-admin\post.php on line 170

    Any help would be smashing!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • solerunner


    I had the exact same issue. I finally figured out that the following 3 fields in the “wp_posts” table had to be set to “Allow Nulls”:

    1) to_ping
    2) pinged
    3) post_content_filtered

    I’m not sure what tool you are using to access you DB but I use Aqua Data Studio (freeware). I just did an “Alter Table” on “wp_posts”, located the 3 fields listed above and then selected “Allow Nulls” for all three.

    Hope this helps.



    Thanks alot solerunner for the reply. Im using PHPmyadmin to access the database…any idea how to make the mentioned changes using that access method?



    Click the database. Look at the list of tables and click the “pencil type icon” (or hover over and find the one that says “edit”). In the list of columns, click those columns and click the change icon at the botton. Change “not null” to “null” for each one.

    As an aside…
    I went down this same road yesterday and finally gave up due to excess heartburn. I had a test scenario of win2000 server, IIS5/PHP5/MySQL5 and all was well.
    But win2k3/IIS6/PHP5/MySQL5 gave me a LOT of these sorts of errors. Regressing to mysql4 resolved ’em, but I’m pretty sure there’s something else going on since mysql5 worked fine with win2k server.



    Thanks for the info HandySolo, Im using the same setup exactly that you had problems with. I will just give it a go with MySQL4 then.



    Tested with MySQL4 and everything worked right away with no problems. Thanks for your time guys, you saved a lot of mine!



    Thanks Solerunner. I had same problems. I should say if it ain’t broke, don’t fix it but I can’t help upgrading to latest versions of software.

    It looks like wordpress needs a new release to get around this new MySQL5 problem.

    I tried to install WP a few months ago and an error prevented me from ever loggin in, forcing me to ditch it in favor of sphpblog. After a system rebuild I tried it again and got the same error as above. I tried the alter table command and it just came up with another db error.
    I guess its back to sphpblog for me.

    I can still confirm this bug in 2.0.1 with MySQL 5- is anybody gonna fix it?


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Field ‘pinged’ doesn’t have a default value’ is closed to new replies.