Support » Plugin: Pods Beaver Themer Add-On » Field connections in Beaver Themer not visible

  • dtp2

    (@dtp2)


    I’m using Beaver Builder, Pods 2.8.2 and Pods Beaver Themer Add On.

    In posts I do see the field connectors, but on pages I don’t. To be more precise. On pages I do see field connectors, but not the ones for the CPT I created. On pages I only see page -> page and page -> user field connectors.

    I would like be able to use the custom fields in both posts and pages. What is different in 2.8 vs the previous version where this was possible and what do I need to do to ge this behaviour back?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Bernhard Gronau

    (@quasel)

    The field connection depends on the preview of BB did you select a page for preview?

    @dtp2

    I think this has been my issue with this plugin too and why I have to use ACF most of the time.

    @quasel I know on one hand making the custom fields available relative to the type of single themer layout or archive layout you are editing seems like good housekeeping but it takes away a fundamental feature that’s easy to do with ACF.

    I want to include post grids using the Posts module on a page to show my custom post types, but because it is limiting the available options to the page, when I’m customizing the loop we can’t access the custom fields created with Pods.

    Please consider a UI change that allows us to pick a post type first and then have it show the fields for that post type. That way it keeps the UI tidy still but gives us a deeper level of control.

    Pretty please? 🙂

    I posted a video demo of this on my own support thread just.

    Plugin Author Bernhard Gronau

    (@quasel)

    Hi,

    back when we built it that way there was no easy way around basing it on the “Preview” – Reason beeing: BB loads most of the data early and the dynamic calls where mostly for rendering but not for new settings…

    I’ll take a look again because that’s a thing that has been bothering me for a while!

    Thx
    Bernhard

    Thread Starter dtp2

    (@dtp2)

    @one3rdnerd That’s exactly my issue and thanks for describing it much better! I was trying to add CPT’s to my grid view as well.

    @quasel I understand what you’re saying and tried, but on pages there is no preview.

    Thanks in advance for your efforts!

    @quasel

    Thanks for your explanation. It would be great if there was a way it could switch from the preview to the settings of the posts module you are editing when adding them here. It’s the icing on the cake for your plugin at the moment I think. I’d love to hear what you discover when you revisit it. If it’s a problem on BB’s end, let’s speak to them and see if there’s a way they can account for this. I’m happy to contact them to explain if you can give me enough info on what we need.

    @dtp2 No problem, you’re welcome. 🙂 If you look at the response on my thread Bernhard mentioned using MagicTags as a workaround. It doesn’t auto get your fields but at least you can use it and copy and paste your pods field names.

    Thanks both.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.