Support » Plugin: Participants Database » Field Attributes w/HTML

  • Hi Roland … THANK YOU again for all the help so far and for the creation of this brilliant plugin.

    For link fields we have added the following attribute:
    # onMouseOver=this.style.color=’red’ onMouseOut=this.style.color=’blue’ style=color:blue;text-decoration:underline; target::_blank

    This works perfectly so that links on the Single Page looks and behalves like a link and when clicked opens on a new tab.

    However, when we add the HTML: style=color:blue;
    To the attribute of a Text-Line field form element — on the Edit-Record page it appears in blue, but is NOT styled on the Single Page view.

    What are we doing wrong?

    Let me know.
    Thanks.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author xnau webdesign

    (@xnau)

    Not doing anything wrong, the “attributes” setting of the field is for forms presentation, so isn’t consistently applied in a read context such as in a single record display. It is also not designed for “style” attributes.

    In general, even though you can use attributes to style individual elements it’s much better to use custom CSS rules for that sort of thing. Doing it that way gives you a lot more flexibility, easier to achieve consistency and is a lot easier to debug and maintain because all your rules are going to be in the same place.

    Thread Starter DavidK

    (@davidk)

    Thank you Roland …. and who said:

    CSS is simple, until it’s not. Then it’s like clawing your eyes out with a rusty spork. Underwater. With your hands tied behind your back.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Field Attributes w/HTML’ is closed to new replies.